Public link not display


Hi everybody,
I’m a new starter on Pydio. Today i’ve got a problem with the public sharing / public link.
Indeed when i share a link with other users the page display :

“file_put_contents(/usr/share/pydio/tmp/failedAJXP.log) failed to open stream : Permission denied”

Did someone meet this problem ? And How resolve it.


your issue might be that you didnt give the rights to www-data to the public folder, first thing you could try is give it rights, another thing might be to just clear the plugins cache.
Try those if the issue is not resolved come back here we will see it in details.


I apply rights in my public folder and change groupe owner to www-data and clear the plugins cache.
But, my issue is not resolve.

Do you have another advice ?


could you look at this file usr/share/pydio/tmp/failedAJXP.log and if it’s there look at whats inside it.


Look the result of contents of /tmp/failedAJXP.log


Hi, can you try to remove this file and try again, i had kinda the same issue when i was trying to reproduce your case "file_put_contents(/usr/share/pydio/tmp/failedAJXP.log) failed to open stream : Permission denied”
i didn’t do specific things but it was working again.

And if i may did you configure everything such as the rewrite rules, output_buffering = off.


I remove the failedAJXP.log and apply rights to all users. I didn’t have the error message, but nothing display on the page.
And Where is the rewrite rules, output_buffering = off ?


you can find it in your php.ini,
to know where this file is located use php -i | grep "Loaded Configuration File"
then you go to this file and modify it, by default it will be output_buffering=4096.


nothing change.
here my configuration :




yes your apache2.conf seems fine but did you put the output_buffering to off.
By the way is your Download URL the same as your Pydio’s ? if yes you could just remove it and change the URI above to /pydio/public instead it will produce the same result, it will be http://**********/pydio/public when you share a link try it to see if it works this way.


I apply :


And apply :

Now, my page display “cannot find this page”


for the output_buffering value it’s this one not the one that you linked above.



yes this one, now set it to output_buffering = off ( for the example i had let it by default which is 4096 ).


I did it, but nothing to display. On my link sharing page. :weary:


And did you try my suggestion ?

let’s see your webserver’s logs.


ok,here is my apache logs :


yeah i thought that it would mention php errors but it didn’t,
is a2enmod rewrite enabled.

edit : do you still get the file_put_contents(/usr/share/pydio/tmp/failedAJXP.log) failed to open stream : Permission denied”just refresh the page, i’ve reproduced it once more and i just needed to refresh the page.