[solved] Unable to install Cells V2

Yeah, with a purchased SSL cert, as LE didn’t seem to want to play ball.

Hello @JapSeyz,

If you don’t mind cleaning (rm -rf ~/.config/pydio/) and reinstalling with the following:

  • INTERNAL: domain:port
  • EXTERNAL: by default should have scheme:domain (nothing to change if you are not running behind a proxy).

Once it is done could you try the sync with a regular workspace.
Also recreate your S3 datasource and tell me if you have any issue.

Regards

Will give it a go when I get home.

Can I simply delete the config and then run the installer again?

Yeah it’s pretty much that, (make sure to clean database + config)

Alright. Will clean the .pydio meta file from the buckets, to ensure they’re completely reset too.

Ps. in regards to the S3 datasource, it seems to be able to find it no problem, as it creates the “folders” in the bucket and adds a .pydio meta-file to each “folder”. But maybe one of the microservices has a prefix or something?

I’ll try to sync with a regular disk workspace first though, and then move it over to the S3 buckets afterwards

Good plan! When the cells server is running, first try to up- and download files on the web interface. Then, set up the sync client. If you have problems with the sync client, try to connect directly to the server (without the proxy).

[SOLVED]

This has been solved, there was a few caveats that the people at Pydio were kind enough to help me figure out.

  1. When using Let’sEncrypt, the external URL should be like this: https://domain.com and the internal url should be like this: domain.com:443

  2. Currently an internalPath with S3 is unsupported or results in a bug. I am not sure if this is written anywhere, but it was observed as we set it up.

If you run into any similar issues, hit me up and I’ll see if I can help you out.

Cheers

1 Like