Cells install on Windows server 2019

I have Cells installed and can login with the credentials I set in the setup.
I purposely set this up without a cert for testing. however, if/when I try to use the Let’s Encrypt or the self signed options, I get the same error in ssl protocol when trying to reach the page.
So the question is, How do I install the cert and not get the error? Each time I’ve done this I’ve had to start from scratch.
I have it currently set to port 80
I would like to use 80 and 443.

Any help would be appreciated.

Whats the error?
I just set the local path when asked on “./cells config sites”, It didnt have any space on the path, for the fullchain.pem and the privkey.pem.

Hello @dagodad ,

Could you share the logs (do not forget to hide sensitive information) It could help me diagnose your issue, unfortunately we do not have much experience on windows server.

Sure what logs would you like? Unfortunately, it is not logging. On the server logs page, it says: Please Not: Empty log entries may mean that the server is running in production mode. Make sure to set this log level by passing the --log=production argument or setting the environment variable PYDIO_LOGS_LEVEL=production"
If I try to set the flag cells.exe --log production
I get the error unknown flag.
In the cells console there is no where to configure it that I can see. Is there a command that I am missing here?

The error occurs after applying the cert, when trying to access the page. The page will not load and the error is “error in ssl protocol”.

In windows i think you can only use a single port. try using only 443, make sure no other service is using that port. also make sure your dns is resolving correctly to the domain you set up in cells config

It happens internally as well when going to the IP.