Pydio Cells API file upload?

api

#1

We were reviewing the REST API in the admin settings from Pydio Cells Enterprise, but we can’t find a clear endpoint to file upload.

If I’m correct, the API v2 is only for the Pydio V8, right?

Can you help us?

Thank you!


#2

Hi,
the Pydio cells endpoints can be found in the interface (edit: forgot to mention it’s in the cells interface),
(edit: my sentence was not really clear but there are 2 options: the interface or the swagger.json sorry if i miss phrased that)
you need this file rest.swagger.json you can find it here for instance https://github.com/pydio/cells-sdk-go.
All you need is to copy the content inside this https://editor.swagger.io/


#3

Thank you @zayn for your answer.

However, I think isn’t necessary to manually generate that swagger file, because it’s generated automatically by default in the web front UI, according to the developer-guide / communication.

The documentation of the HTTP REST API of Pydio Cells is generated with Swagger and can be found in the web front UI. In settings workspace, go to All Plugins >> REST APIs .

Researching in the Pydio Official repo I found that the way to do file uploads is through S3 REST API.

I will open another thread to ask you how can I manage files with Pydio with local storage by the backdoor (gRPC or REST API).

Thx!


#4

Hi, @zayn and @Yamilquery
I’m also confused how to upload files via the REST API. AWS says to prepend the bucket name, which would be the default io, correct? But my dns doesn’t route io prefixes so do I also need to change that? On this page it says to prepend the bucket name but then the url provided here appends the bucket name to the normal file hosting url. Which url am I supposed to use? my current PUT commands via Postman either return a “No Response” (prepending the bucket name), loading webpage ( omitting the bucket name entirely) or an error (via appending the bucket name io followed by the workspace):
AuthorizationQueryParametersErrorError parsing the X-Amz-Credential parameter; incorrect service. This endpoint belongs to "s3"./io/common-files/general/so.png3L1373L137

example url by appending the bucket name: https://filesharing.mydomain.me/io/common-files/general/newfile.png

EDIT: Oh I see I had to put “s3” in the advanced>service name section of postman