Problems with upload files pluploader

i have a problem
i create a folder and share with upload files permission
i use pluploader plugin
but the page me retorn a error
i attached a image
when i upload a file normaly the error does not occur

so basically the error occurs only when you upload a folder, when you upload a file it doesn’t ?

hi,thanks for your answer
so the problem occurs when i share a directory and enable upload files
when i open the link to share and click on upload the error occurs
if i log in pydio with a user and upload a file the error does not occur,i can upload the file normaly

i will do some testing to see if it happens to me and see what’s going on.

after installing and using Pluploader i understood that you cannot upload folders, you can only upload files.
I could only select files with the interface as seen on my screen capture :

when i tried to select folders it would just not let me select them ( the open button was unavailable ).

ok so the problem occurs when i open the page of share
i cannot view the buttons
i create a folder with my user and share with upload files permission
when i open this link for upload a file i receive a error

so it happens only with files that are uploaded with Plupload ?
sorry if i misunderstood you.

i enable only plupload
problems occurs only with a share with permission of upload files.
i have a approval environment and the problem does not occurs

could you try to clear the cache you can do that as i’ll show you :
go to the cache file located in <your-pydio>/data/cache and use rm -f plugins_*, your issue seems to be that the shares cannot use pluploader, you should get a look at your shares url too,
if you did a fresh install and enabled every thing such as rewrite rules etc … you should just have the following screen as you said above.

edit : you should also restart your webserver or php depends on your webserver.

how can i see the share url?

You, can find it Menu > Application Core it will look like this the server url is used as the base and then it adds the /public and such.
so basically a sharing url with my example would look like this https://localhost:9876/public/72bf8e.

ok i attached a picture from my config

i set it up an pydio installation in my notebook and it did not work either

ok,i download the source of pydio community and install in my notebook
the error persist
you can test? the test is simple,i create a folder with user admin for example and share this folder.
after i open the link to share and cliquei em new > upload
when page to upload files open the error occur

Maybe is a dumb question, but did you installed the plupupload sources in the plugin directory ?
They are not supplied with pydio, So setting pluploader without installing the library brings a lot of issues
You need to download the following file: (the pydio documentation says it supports version 2.x but version 3.1.2 works as well)
create a directory plupload in the /plugins/upload.plupload one
Copy the content of the js folder in the zip inside the directory plupload.

Pydio works rather well, very often the bugs reported here could be solved by simply reading the instructions or by looking at the web server error log.

yes i completly forgot to ask if did you downloaded pluploader and moved in the plugins files under uploaders.plupload and take the js file that is located in the downloaded file move it to /plugins/uploaders.plupload and rename it plupload.
actually heres a screen of the plugins menu :

yes i download the plupload and move to uploaded.plupload folder
i attached a print of files

what you actually have to do is download it (pluploader), then cd into(unzipped pluploader folder)it there’s a js folder you have to rename this folder to plupload and mv/cp or w/e it to uploader.pluploader

i download pluploader from site,unzip and copy the folder js to uploaded.plupload with name plupload
after i restart apache and test but no success
i test in server and in my notebook

your issue is weird, and you have the plugin enabled, you could to clear the cache (pydio’s) and try with another browser or incognito browsing to see if the issue is still here.

I think it happens with the url of the share
when i upload a file with my user the plugin works
but when i access a public link the problem occurs