Sharing file error


#1

When I try to share any file I have this error for public sharing, see the attchments.


#2

Hi,
could you tell me your OS, database version and php, if it is a pydio 8.

Also did you enable the rewrite rules on apache?


#3

Client : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36
Crypto Extension Detected : OpenSSL
Command Line Available : Yes
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 2000M
Memory Limit : 1024M
Max execution time : 300
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : Linux
Session Save Path : /home/athemovv/php_sessions
Session Save Path Writeable : Yes
PHP Version : 7.2.15
Locale : C
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : Yes
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 2097152000
PHP Post Max Size : 2097152000
Users enabled : Yes
Guest enabled : No
Writeable Folders : [cache:true,
data:true]
Zlib Enabled : Yes


#4

thanks,
now let’s see if you have the right configurations on apache, do you have the rewrite rules also did you modify the AllowOverride to All (this setting is inside the apache2.conf) and/or inside your virtual host file like this:

<Directory /var/www/pydio/>
      AllowOverride All
      Require all
</Directory>

#5

I have to modify the htaccess file?


#6

If you are using it yes,
for my case i’m using a vhost/


#7

My shared hosting not consent this kind of settings.
Do you have any other suggestions for fix this issue?


#8

Unfortunately this must be changed,
you can see on the first paragraph that this setting has that impact,
here: http://www.htaccess-guide.com/

and also i assumed that your webserver was apache but could you confirm that this apache mod is enabled, rewrite (you can a2enmod rewrite & then restart apache).


#9

My hosting says that is a bug of the CMS


#10

Have you got any updates?


#11

Hi,
unless we could modify the webserver’s config file, i cannot see what we could do to move on.

So basically you access your pydio instance through this url http://repository.themovimagecompany.it,
in the main options you should have the same url (you can replace my 192.168.0.116, with yours):

Yeah my guess is that you do not have the allow override setting.