Issues with uploading and file sizes

php71

#1

So, i have been runing pydio for some years now, with new installs over the old ones that have broken in some way or another after 1-5 upgrades xD So now im here again with new issues that all of a sudden just showed up after maybe 3 months of not upgrading or modifying anything in the pydio files. i am running the same version of PHP (7.2.8) No apache upgrades nor any MySQL upgrades.

So to the issue: File uploads says files are to big, i have checked the php.ini and file size limit is 8192M just like it should (moving/sharing big files most of the time) when i go in to pydio settings > Uploaders Options > File size: the already filled in number is: -2147483648 (not entirely sure why it is like this?) and simply changed that to 8192M instead like i were hoping it should have been, saved and then restarted the server. when i come back in to pydio the file size once again is -2147483648 and not sure why… would you be able to provide som information about this particular issue? Im willing to provide all the information i can to solve this issue. i have a client im going to on monday 21 Jan providing some files for him to play with but i simply can’t upload them. Can i sync two folders with the same client just adding another “sync”? from the sync client for Windows?

Pydio 8.2.2

EDIT:

I upladed the file to the repository using FTP and this error comes up whil i try to view it in pydio:

Params: FsAccessDriver.php
message=filesize(): stat failed for pydio://pydiouser@1/folder/to/file/BACKUPS.zip

not sure if that helps anything but the file is 2,45 GB and should definitly be able to be read.

also the folder is showing up as empty even tho there is more files in it.


#2

Hi,

this value depends on your upload_max_filesize inside of your php.ini file.
(what i mean is that it will be filled with whatever value you’ve got in your php.ini file).

The value on the ui can only be lower that the the value inside the php.ini, if you want more you have to increase the values inside the php.ini.


#3

Well that’s the thing, I got php.ini set to 8192M where does it get that -2147483648.

So basically what you are telling menus that bit should be fine to just set 8191M in pydio?


#4

Hi,
yes you can set the same value (which should be done automatically), would you mind telling me the path of the php.ini file that you modified ?


#5

Here’s the rule for setting up the 3 different ‘memory size’ settings in php.ini:

If the upload_max_filesize is larger than post_max_size, you must increase post_max_size so that it is bigger than upload_max_size.

If the value of post_max_size is larger than memory_limit, you must increase memory_limit so that it is larger than post_max_size.

If you’re at Pydio 8, and haven’t set up Pydio Booster, it’s probably a good idea to do that as it’ll alleviate the problem with php memory size limitation


#6

This solved the issue! Thanks!