PHP update 7.1 to 7.2 on Archlinux breaks pydio


#1

Update via pacman from PHP 7.1 to 7.2, Archlinux, Pydio 8.0.1

I just want you to know that the update above ends in an errormessage in the browser:

  • message type=“ERROR”>Function create_function() is deprecated</message

Temporary solution:

Downgrade these packages to 7.1

  • php-7.1.12-1-x86_64.pkg.tar.xz
  • php-apache-7.1.12-1-x86_64.pkg.tar.xz
  • php-gd-7.1.12-1-x86_64.pkg.tar.xz
  • php-imap-7.1.12-1-x86_64.pkg.tar.xz
  • php-intl-7.1.12-1-x86_64.pkg.tar.xz
  • php-mcrypt-7.1.12-1-x86_64.pkg.tar.xz

#2

Hi this one is not really easy, as create_function() appears in some external libraries, not in pydio code. Stick to php 7.1 until the libs are updated.


#3

Thanks for your reply Charles.


#4

Any news on this issue?

So, since today i’m not able to patch my system anymore. Everything i tried without updateing the packages named above breaks something else (e.g. postfix) or will not let apache start up correct. The only possibility for me, and for now, is to disable my Pydio-instance.

Any hints are welcome!


#5

hi, did you check the Github repository? there are a couple of commits regarding 7.2 support. We will release a Pydio8 version for that very soon
charles


#6

Thanks for your reply. I’ve done an manual update to Pydio 8.2.0. So far no problems and seemless update without issues. Thanks!