Update from 8.2.1 to 8.2.2 fails


#1

Hi,
I´m running a pydio Server on Ubuntu 14.05 LTS with php 7 and apache2 installed. The server ran pretty well so I did not change anything in quite some time. Recently I saw that there were some updates available so I created a snapshot and tried to install. Everything went well up to 8.2.1 but when I tried to go to 8.2.2 I ran into the following problem:

[Mon Dec 10 17:09:14.418338 2018] [:error] [pid 1555] [client x.x.x.x:61146] PHP Parse error: syntax error, unexpected ‘function’ (T_FUNCTION), expecting identifier (T_STRING) or \\ (T_NS_SEPARATOR) in /usr/share/pydio/core/vendor/zendframework/zend-diactoros/src/functions/marshal_headers_from_sapi.php on line 10, referer: http://myserver/pydio/settings/plugins/manager

I tried the usual, deleting caches and stuff like this with no success, restored the snapshot and everything is running like a charm again.
Any ideas?

Cheers
Eckart


#2

Hi,
sorry for the late reply,
are you still confronting the issue?