Issue with public link


#1

Debian 9
Pydio 8.2.2

Hello,

I use webFTP for auth my users.
My master driver is FTP auth
My secondary driver is DataBase

I’m admin on my pydio server, i use the same login/pw from my FTP.

Everything works great, but i cannot share public link with random people (when i do not use FTP auth this function works great)

Now when I want to share publick link, pydio create a user like this:

I can’t delete this user.
And shared link does not display anything (but link is working)

Any idea ?

thank you :slight_smile:


#2

Hi,
this is a temporary user don’t worry about it and do not try to delete it else your public link might have issues.


#3

thank you for your fast reply :slight_smile:

Anyway, the public link does not display anything, but the link is working, any suggestions ?


#4

mmm,
could you clear the pydio cache, rm -rf /var/www/pydio/data/cache/plugins_* and also rm -rf /var/www/pydio/data/cache/i18n/* just to be sure.


#5

No changing, still a blank page with correct page title (of my share) and copyright on bottom right.


#6

what is the ressource(the type) that you are sharing?


#7

It’s a folder (with files inside) from my FTP (I use FTP Auth master driver and FTP workplace Driver)


#8

mmm, try with a single text file for example i want to be sure about the issue.


#9

Same, I create “file.txt”, in an empty folder from my FTP “tmp” and try to share public link of the folder, same issue:

still a blank page with correct page title (of my share folder, “Pydio - tmp”) and copyright on bottom right but no files inside.


#10

Hi,
can you try to put the DB auth storage as master and the FTP as secondary.


#11

It works !

Thank you.

is this a bug or something ?


#12

did it also fix your other issue, i saw that you re posted.


#13

No, I still cannot delete files I created (but I can delete from another ftp client, so I know right is good) and auto create succefully login user does not work.


#14

Hi,
indeed the auto creation does not seem to work I will instigate that.
for the deletion it should be a rights issue, i just tested and when i created a file with my ftp client that had a non ftp user i was not able to perfom a delete but when i chown ftpuser:ftpusergroup it worked and i ws able to delete it from the user interface


#15

For deletion of files/folder:

I create a file from pydio in a FTP directory (i’m login with my FTP user “qwrty”), I look permission on my server, it was the same, belong to “qwrty”.

When i tried to delete from Pydio, i can’t:

When I tried to delete from another FTP client (like filezilla) I can.


#16

Hi,
i would like to know what plugin did you enable,


and also the one on your workspace,
like this,
download

edit: also make sure to have libssh2 installed,


#17

Hey,

thank you for your feedback.

libssh2 is installed.

I checked into my plugins => storage driver => I do not have FTP over SSH enable, only FTP server.

My workspace is mounted with FTP server not FTP over SSH.

Should I try with FTP over SSH ?


#18

Hi,
yes sorry if i was not clear about it, but yes you have to enable it and use this one.


#19

I will try and come back to tell if it works or not :slight_smile: