Public Sharing not working

public

#1

Hi,

I’m running Pydio 8.0.1 on FreeBSD 11.1-RELEASE and whenever I select the “Share” option the checkbox never checks and I see these messages in the log files:

stat: illegal option -- c
usage: stat [-FLnq] [-f format | -l | -r | -s | -x] [-t timefmt] 
[file|handle ...]
ls: illegal option -- -
usage: ls [-ABCFGHILPRSTUWZabcdfghiklmnopqrstuwxy1,] [-D format] [file 
...]



stat: illegal option -- c
usage: stat [-FLnq] [-f format | -l | -r | -s | -x] [-t timefmt] [file|handle ...]
ls: illegal option -- -
usage: ls [-ABCFGHILPRSTUWZabcdfghiklmnopqrstuwxy1,] [-D format] [file ...]
stat: illegal option -- c
usage: stat [-FLnq] [-f format | -l | -r | -s | -x] [-t timefmt] [file|handle ...]
ls: illegal option -- -
usage: ls [-ABCFGHILPRSTUWZabcdfghiklmnopqrstuwxy1,] [-D format] [file ...]
stat: illegal option -- c
usage: stat [-FLnq] [-f format | -l | -r | -s | -x] [-t timefmt] [file|handle ...]
ls: illegal option -- -
usage: ls [-ABCFGHILPRSTUWZabcdfghiklmnopqrstuwxy1,] [-D format] [file ...]

The Web server is Apache 2.4 with a Postgresql backend.

It’s probably due to the fact that the FreeBSD version of the “ls” command is BSD based so GPL “ls” syntax won’t work. I wonder if there is a fix or modification that can be made to get it to function properly for portability?


#2

Hi Johny, welcome on the new forums :slight_smile:
That’s strange, it’s only happening when you share? Did you maybe enable the “Probe Real Size” option?


#3

Many Thanks for the response Charles.

I tried disabling the “Probe Real Size” option but unfortunately the same thing.

I’m not sure where to begin debugging the Public Shared Link issue??

Under the Admin interface and Application Parameters -> Application Core the “Public Base URI” and “Download URL” are both set to “/public”

I use: https://server.domain.com as Pydio URL if that makes a difference.

Another thought could be that last time we looked at this issue in the previous version we determined that Postgresql wasn’t writing the link into the database for some reason even though the Pydio user has full access to it.

Unless it’s got something to do with writable folders?


#4

Just as a quick look this is what Postgres is doing:

   [7-1] LOG:  statement: set client_encoding to 'utf8'
   [8-1] LOG:  statement: DELETE FROM "ajxp_mq_queues" WHERE "channel_name" = 'nodes:1'
   [9-1] LOG:  statement: INSERT INTO "ajxp_mq_queues" ("channel_name", "content") VALUES ('nodes:1', '\x1d8e510b82301446ffcbfd03b98d95dc3d8dbae8ca4a9cfae08b4842186992540fb2ff1edbdbc7e170f83ae4b82eb843d867862ea505d521f34870841f7d7a396f697e4ec787aef3f76d9463faadcc5d9445737a7959785922e8ccd4046a402659c4a5642256215c592a5a730015b4ae1f87c96f162124c5b5cadb5c976920081b50ce2d18239cc95a9d50f813e1eadc1f')
   [10-1] LOG:  statement: DELETE FROM "ajxp_mq_queues" WHERE "channel_name" = 'nodes:*'
   [11-1] LOG:  statement: INSERT INTO "ajxp_mq_queues" ("channel_name", "content") VALUES ('nodes:*', '\xc5945d4f83301486ffcad21fe00afde4a02664920d9d6e611f17de90027561d960a14c6316febb1413e7a5de6c77cd9bf7bc3d7d7a5a052e9c0c0840a36914be2c17c857e05889b8803ec263ce0e3c3ceccac76db09ed7d99eed27efab684396f1eb5365cdc49a19a0601aad43e417e03007bb8c3944fa7df06a11c649f480fcdea6f27d51dab583018de3d96a9ecc83e5a457000d91dfb60624a0e770b108c661df0f855301d89f59dd34f968a78c4156edf3b3aa6c74d9d804ca01ddd67a57a93c294ad3d4c7ac29aa7250a55b9d3577a8d687ca144d557f26bbc23468786fabbaa2a3d17594f74d74c7a6ec2dc5994ea91699d53c407b6d8cdae878f44f3e7ff5b5bf77b1b760c0ed78e01bd793844a8c07df58a9a0bc7377942f87432a17732e04ce29bb360e07132abc330ec9448fc3bd1c8e9c72a5524c53e25e7d3a88e379849e71788cf538c8e570a8dce30253219923af3e1d844b8e7f70747f907d2c6dfb05')

Inside the actual tables I have two headers: channel_name & Content bytea

underneath the headers in the rows I have: nodes: * & nodes:1

with both “Content” columns containing ‘binary data’

To me it seems as though it’s adding the information then removing it??

Maybe I just need to recreate the table?


#5

Hi, can you try to switch the “Messaging” from mq.sql to mq.serial ?


#6

Hi Charles,

thanks for the suggestion but it didn’t work :frowning:

In the Pydio log files I just discovered this error:

ERROR	b86a11ec7a3e	core.mq	core.mq	sendMessage im	Failed to publish message; required 1 for success, achieved 0. Errors were: Could not connect to 0.0.0.0:4150 (Connection refused [61])

Could this be the reason??

Running:

netstat -anp tcp |grep 4150

Doesn’t show anything as running on that port. Should there be a service running which isn’t?


#7

Found the answer to that! It isn’t anything to do with the Public Link issue…

I turned on the “Websocket Server” without understanding fully how it worked. Of course for it to function it needs to be proxied by Apache. So I turned it off and the error has disappeared.


#8

Ok cool! Can I close the topic then?


#9

Hi Charles,

sorry if my responses were misleading. The actual issue is as the title says: “public links” not generating.

Unfortunately this still persists. The other things that I mentioned was me clutching at straws trying to figure it out but actually hitting other errors.

In reality I am not sure where to begin with the debug procedure. I’ve looked at the logs from my Postgres DB, checked the Apache and Pydio logs but none of them actually say anything as to why or where the problem lies.


#10

Did you actual try my previous suggestion of switching to mq.serial instead of mq.sql ? The latter maybe broken w. postgre.
-c


#11

Hi Charles,

I did try that!!

I have just redone it now too, Admin -> Settings -> Pydio Booster -> Server Internals :: switch to mq.serial :: Save Settings

Then go to home and test image. Click “Share” and “Public Link”. The cursor changes to a black circle with a line in the middle and the checkbox is still empty :frowning:


#12

hi again

… i’m a bit lost here

PM access ?


#13

Hi Charles,

how do I PM from this forum? I tried looking all over for a menu option but I couldn’t find one?

Thanks.


#14

do you have a “Message” button in the popup when clicking on my name?


#15

Unfortunately not :frowning:


#16

Hi Charles, did you get my response to your PM??


#17

@JohnnySSH - Did you ever get this sorted? I have been using Pydio for at least a decade but can’t seem to get public shares to work with 8.0.2 - I get the same circle with line icon you mentioned.

@charles - any ideas on where to look to get this fixed?


#18

@adrianbj this thread is dead… can you maybe reopen a new one with a proper description of your issue (screenshots maybe?)
Thx
Charles


#19

Sure - I just put together a very detailed post, but first it would only allow one image and then akismet decided to hide the post.


#20

Hi all,

sorry I never got this working. Also I I’m not sure even if the forum software is working properly for me as it seems that my PM’s never got through either?? :frowning:

Though I’m not trying to bump or revitalize a dead-thread…