Best VPS to install Pydio Cell

I want to install Pydio,
I plan to buy a starter VPS with the following configurations:
1 vCore
2 G ram
20 GO SSD Sata
is this enough?
Which is the best system to install Ubuntu or Debian§
Thank you.

This would really depend on your “usage load” : amount of users, amount of files, etc… Probably we would suggest at least 2vCore and 4G to be rest assured for the future.

@charles the users will not be more than 4 and the files will not exceed the 3Giga… it is mainly documents, no videos, no images… the uploads maybe once a while…
I already bought the vps, installed Debian… still i am not able to intall…
When I select the web installer… if got this
how can i change the to my own ip or domain!

okay !
If you know your VPS external IP, you have to provide this IP to the cells configure command, use cells configure --help to get more examples and parameters docs, e.g:

cells configure --bind "your_ip"

Installation Server is starting…
Listening to: https://51...*:8080

2024-03-26T16:04:31.407Z INFO starting { “service”: “”, “hook router to”: “/a/install”}
2024-03-26T16:04:31.423Z INFO pydio.web.install ready
2024-03-26T16:04:31.424Z INFO starting { “service”: “”, “hook router to”: “/a/config”}
2024-03-26T16:04:31.759Z INFO ready
2024-03-26T16:04:31.761Z INFO ready
2024-03-26T16:04:31.763Z INFO pydio.server.caddy :white_check_mark: Using the loc al CA at “rootCA.pem” :sparkles:
2024-03-26T16:04:32.093Z INFO pydio.server.caddy :white_check_mark: Created a new certificate valid for the following names :scroll:
2024-03-26T16:04:32.094Z INFO pydio.server.caddy - “”
2024-03-26T16:04:32.094Z INFO pydio.server.caddy :white_check_mark: The certifica te is at “94c629a7a3ae1c2d125bb4ebc94afa96.pem”
and the key at “94c629a7a3ae1c2d125bb4ebc94afa96-key.pem”
2024-03-26T16:04:32.095Z INFO pydio.server.caddy
2024-03-26T16:04:32.095Z INFO pydio.server.caddy
2024-03-26T16:04:32.096Z INFO pydio.server.caddy :point_right: If you are be hind a reverse proxy, you can either install the RootCA on the proxy machine tru st store, or configure your proxy to insecure_skip_verify for pointing to Cell s.
2024-03-26T16:04:32.096Z INFO pydio.server.caddy :point_right: If you are de veloping locally, you may install the RootCA in your system trust store to see a green light in your browser!
2024-03-26T16:04:32.096Z INFO pydio.server.caddy :spiral_notepad: To easily ins tall the RootCA in your trust store, use GitHub - FiloSottile/mkcert: A simple zero-config tool to make locally trusted development certificates with any names you'd like.. Set the $CAROOT environment variable to the rootCA folder then use ‘mkcert -inst all’
2024-03-26T16:04:32.097Z INFO pydio.server.caddy
2024-03-26T16:04:32.101Z WARN pydio.server.caddy admin - admin en dpoint disabled
2024-03-26T16:04:32.101Z WARN pydio.server.caddy tls - stapling O CSP{“error”: “no OCSP stapling for [51...]: no OCSP server specified in cer tificate"}
2024-03-26T16:04:32.102Z INFO pydio.server.caddy http.auto_https - skipping automatic certificate management because one or more matching certifi cates are already loaded{“domain”: "51.
.*.*5”, “server_name”: “srv0”}
2024-03-26T16:04:32.102Z WARN pydio.server.caddy http.auto_https - automatic HTTP->HTTPS redirects are disabled{“server_name”: “srv0”}
2024-03-26T16:04:32.102Z INFO pydio.server.caddy tls - cleaning s torage unit{“description”: “FileStorage:/var/cells/caddy”}
2024-03-26T16:04:32.103Z INFO pydio.server.caddy tls - finished c leaning storage units
2024-03-26T16:04:32.103Z INFO pydio.server.caddy tls.cache.mainte nance - started background certificate maintenance{“cache”: “0xc0012ce100”}
panic: server.Start caddy: loading new config: http app module: start: listen ud p :8080: bind: address already in use

This is what I get… no browser opens!

When I do the cells start
pydio@vps-f****:~$ cells start
Package: Pydio Cells Home Edition
Version: 4.3.6
BuildTime: 26 Feb 24 12:41 +0000
Git Commit: a61fec4f12a9792a5b94dfed24b887a0767e5a50
Go Version: go1.21.7
OS/arch: linux/amd64

Registry: mem:///registry
Broker: mem:///broker
Config: file:///var/cells/pydio.json
Vault: file:///var/cells/pydio-vault.json
Keyring: file:///var/cells/cells-vault-key
Certificates: file:///var/cells/certs
Cache: bigcache:///cache
ShortCache: pm:///shortcache
Queue: mem:///queue
Persisting Queue: file:///queue

Hostname: vps-*******

Metrics: false
Profiles: false

Build Settings:
-buildmode: exe
-compiler: gc
-trimpath: true
DefaultGODEBUG: panicnil=1
GOARCH: amd64
GOOS: linux
GOAMD64: v1
vcs: git
vcs.revision: a61fec4f12a9792a5b94dfed24b887a0767e5a50
vcs.time: 2024-02-26T12:18:28Z
vcs.modified: false

2024-03-26T16:09:11.363Z INFO ready
2024-03-26T16:09:11.364Z INFO pydio.grpc.config ready
2024-03-26T16:09:11.364Z INFO pydio.grpc.registry ready

then nothing happens…

now if I got to the 51...*:8080
i got thi
Client sent an HTTP request to an HTTPS server.

this one is quite clear :wink: : bind address is already in use, try using a different port !

How can I change the port 8080 to another port! I didn’t select that :slight_smile:

Run cells configure sites

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.