Help installing Cells

Hi

I’m trying to install cells on a virtual server running Ubuntu 18.04 with Plesk Onyx for a study-project. I have some intermediate knowledge on Linux and running a web server and I can find my way around with a bit of advice, but I’m by no means a pro and would appreciate any help!

I tried installing via the method shown for Ubuntu/Debian. I downloaded to the corresponding host directory /var/www/vhost/mydomain/sub.mydomain/, set right, created the user pydio. But of course this user doesn’t have any privileges there so I can’t run cells. When I run the installer with another user or even root, the install routine goes through. I’ve set localhost:8080 internal and https://sub.mydomain:8080 external, created a new certificate, but after the installer is done I can’t open the web interface (endless loading).

I also tried it via Docker in Plesk, but after starting the container it doesn’t show up in the Docker Proxy Rules panel for the domain.

Can someone please help me to get this running?
Thank you very much.

Hello @devilsinkpot,

So to install the binary and cells you need the following:

  • you should install and run Cells under the same user, because by default the install folder is located here: ~/.config/pydio/cells (therefore the home user)
  • for the internal and external URL, you are using the same port it should be perfect.
  • you could try first to install only with HTTP to make sure that your domain is working, then add TLS (I can explain how you do it after an installation)

By the way we have a new release on the way that will simplify All if that process, it will now require you only to put a Bind Address, in your case only “localhost:8080”.

I am not familiar with plesk, but maybe you could show me the command that you used to run the container.