URL doesn`t open during Cells installation process

Hi there,

during the Cells installation via Terminal, this line appears:

"Opening URL MyDomain in your browser. Please copy/paste it if the browser is not on the same machine."

Unfortunately nothing happens after this step.
No Browser opens up and if I copy/paste either internal or external URL, no Cells installation dialog appears. Both URLs aren’t reachable.

Is this a known behaviour? Can anyone help?

Thanks in advance.

BTW: Clean install on fresh Ubuntu 18.04. (on VPS) All standard Ports are open and A Records working. I followed these instructions: https://pydio.com/en/docs/cells/v2/debianubuntu-systems and https://pydio.com/en/docs/cells/v2/cells-installation

What are you entering for the Internal & External URLs?

Hi,

it’s external: https://cloud.null9.rocks and internal: https://217.160.43.149:8080

Hello @null9,

the browser tab opens only if you install Cells on the same machine as the OS graphic interface,

if you are installing on a remote server, then you must access the URL defined with EXTERNAL_URL.

Hi Zayn,

okay, I see. But when I paste the external https://cloud.null9.rocks in the browser, nothing happens as described. Have you got any idea to solve this?

Thanks so much!

@null9,

Could you try with the following settings:
INTERNAL = https://cloud.null9.rocks/
EXTERNAL = https://cloud.null9.rocks/

also, are you making use of let’s encrypt or your own certificates?

Hi zayn,

sorry for the delay! … Yes, I make use of Let’s Encrypt.
And sorry for my unsophisticated approach to the Pydio installation. I’m new in the command line business , )

I just opened the config file (./cells config list) and this warning came up:

Warning: no private IP detected for binding broker. Will bind to 217.160.43.149, which may give public access to the broker.

Maybe this makes it more clear to you what’s happening?

Back to Let’s Encrypt. So far I just confirmed the usage of Let’s Encrypt during the Cells installation. Now, do I have to Install anything else on the server? (probably yes … maybe Certbot or something?)

Sorry again for all these questions. I’m using Pydio for quite a while, but since the installation of Cells require some Terminal action, I have to go through this.

Cheers Tim

P.S.: Oh, and how do I change the internal URL again? ; )

Hey @null9,

If you are on Cells 2.0 you can make use of the following command ./cells config proxy url

No worries everything is being handled by Caddy (our embedded webserver)

Once you changed both internal and external to the same domain, could you try to redo the same steps and see if you still see this warning.

Hi Zayn,

thanks for your ideas!
Unfortunately I get the same warnings and don’t see any Cells browser installation dialog under internal and external URL.

Can I give you any log file or anything else that enables you to inspect this a little deeper?
It’s most probably a beginners mistake ; )

Thank you!
Tim

hey @null9,

Would you mind listing me all the settings that you have used for the installation process?

If you are running Cells directly through the cli you could copy paste the logs displayed otherwise if you are making use of a systemd service, see if you are redirecting the logs inside a file.

Hi zayn,

Cells is up and running. (On CentOS 7 now) But still not reachable!

These are the Warnings/Errors I get:

Warning: no private IP detected for binding broker. Will bind to (My IP Address), which may give public access to the broker.

WARNING: File descriptor limit 1024 is too low for running Pydio Cells Home Edition in production. At least 8192 is recommended. Fix with “ulimit -n 8192”.

ERROR pydio.gateway.proxy Could not run {“error”: “registration error: acme: Error 403 - urn:acme:error:unauthorized - Account creation on ACMEv1 is disabled. Please upgrade your ACME client to a version that supports ACMEv2 / RFC 8555. See https://community.letsencrypt.org/t/end-of-life-plan-for-acmev1/88430 for details.”}

Ho do I generate the logs you’d need to get a clue?
And how do I edit the “private IP”?

Thanks so much!