Change external URL, maybe?

Dear Pydio/Cells user,

I have installed the latest (cells home V1.6.1) version of Cells, during the install process i don’t changed internal_URL and external URL. Actually this both variable is my private IP address 192.168.0.x/24. So, i can connect to my Cells interface using my private IP and port 8080 without SSL.

But actually i want to used my cells conf outside my personnal network. It’s why i configured an apache 2 server on a new VM (in my DMZ) with proxy_http enable. In fact, the configuration seems to work, but on my web browser everything block on “loading” cells interface (grey screen and Cells logo).

Maybe my external URL is the problem? If yes, how can I change it without making a new install/configuration (without loosing my actual configuration?

Best regards

Hello,

we have a Apache reverse proxy how-to, it should be of help to you.
https://pydio.com/en/docs/kb/devops/running-cells-behind-apache-reverse-proxy

Thanks for the link, I’ve already read it.

So it’s why my question was how can i change the External/internal URL without installing all from scratch (without loosing my actual configuration)?

Best regards.

You can edit the pydio.json file under ~/.config/pydio/cells/pydio.json (the home of the user running cells), then look for internal url and url.

Hello,

On a new server i install a new Pydio/cells system. And now nothing work. It’s why i don’t understand the way Pydio used Internal URL and External URL.

On my install, i choose “192.168.110.121:8080” as an Internal URL and “http://pydio.mydomain.com:8080” as external URL. And on both URL i can’t connect to Pydio system.pydioLoading

Can you help me to understand the reason.

Best regards.

On my logs, i have this :

*2019-09-19T15:15:25.388+0200 ERROR Error while applying modifiers to registry! {“error”: “{“id”:“go.micro.client”,“code”:500,“detail”:“Error creating stream: rpc error: code = Unavailable desc = all SubConns are in TransientFailure, latest connection error: connection error: desc = \“transport: Error while dialing dial tcp 192.168.110.121:33427: connect: connection refused\””,“status”:“Internal Server Error”}”}
*

Best regards.

Hello,

External URL should differ only in some specific case (reverse proxy for instance),
in your case:

  • use 192.168.110.121:8080 for internal and external
  • or if you have a registered domain name then http://pydio.mydomain.com:8080” for both.

Hello Zyan,

I’ve try every previous point, with the IP address, from outsime my nework, Pydio interface stop on my previous screen (grey with Pydio logo and loading … information), from inside, no problem.

With my registered domain as Internal and External URL the probem is the same.

My reverse proxy seems to worked cause i’m on the web server, but Pydio interface blocked somewere, and i don’t know where and why.

A tail - f on my cells.log file give me this error :
2019-09-23T23:37:42.460+0200 ERROR Error while applying modifiers to registry! {“error”: “{“id”:“go.micro.client”,“code”:500,“detail”:“Error creating stream: rpc error: code = Unavailable desc = all SubConns are in TransientFailure, latest connection error: connection error: desc = \“transport: Error while dialing dial tcp 192.168.110.121:34915: connect: connection refused\””,“status”:“Internal Server Error”}”}

Any idee?

Best regards.

Hello,

do you mind giving me the following details:

  • Internal_URL
  • External_URL
  • Server address or domain
  • Reverse proxy address or domain
  • and your reverse proxy config

Hello,

I can’t put my conf here cause the forum said : Sorry you can not post e link to that host.

  • Reverse proxy configuration

https://www.writeurl.com/text/odmnjq08i53x3yxuv1xs/adf8inb6wqyzxv9svdaw

Bests regards.

Hello Zayn,

Do you have any idea about this problem? Is it a configuration problem?

Best regards.

Hello @drz,

your configuration seems to point that there is no proxying,
could you change the internal_url to (192.168.110.121) to bind cells to the server it’s running in.

Then your external_url I assume is the address to your reverse proxy.
Now inside your reverse proxy configuration, you will proxy all requests from http://pydio.mydomain.com:8080
to 192.168.110.121:8080.

Then your apache config will look like this

Listen 8080
<VirtualHost *:8080>

  ServerName pydio.mydomain.com
  ServerAdmin pydio.mydomain.com
  AllowEncodedSlashes On
  RewriteEngine On

  #Proxy WebSocket
  #RewriteCond %{HTTP:Upgrade} =websocket [NC]
  #RewriteRule /(.*) wss://127.0.0.1:8080/$1 [P,L]
  ProxyPassMatch "/ws/(.*)" ws://192.168.110.121:8080/ws/$1 nocanon

  #Finally simple proxy instruction
  ProxyPass "/" "http://192.168.0.172:8080/" nocanon
  ProxyPassReverse "/" "http://192.168.110.121:8080/" nocanon

  ErrorLog ${APACHE_LOG_DIR}/error-ssl.log
  CustomLog ${APACHE_LOG_DIR}/access-ssl.log combined
</VirtualHost>

Assuming the following:

  • You reverse proxy is under this address/domain pydio.mydomain.com
  • Your cells is under the following address (internal_url)192.168.110.121:8080
  • you want to access Cells with your reverse proxy under this domain http://pydio.mydomain.com:8080

Dear Zayn,

With that configuration (internal URL with my IP and External URL with my domain name), i have :

  • when i try to connect to my pydio web interface inside my network, everything stop on loading screen with pydio cells logo.
  • when i try to connect to my pydio using my domain name, i have this issue : “404 Site FQDN:8080 is not served on this interface”

Actually, every configuration i try seens to block somewhere, but i don’t really understand why!

Is there a way to give you more details (logs)? if yes, where i can find them?

Best regards

Hello,

could you show me your reverse proxy logs(apache) and caddy(the webserver included in Pydio Cells) logs, you can find the Caddy logs inside ~/.config/pydio/cells/logs/.