[Solved] cURL Error 7: Failed to Connect

#1

After a significant amount of test and changes, I’ve finally set my instance to the correct internal and external URLs/Ports/etc and was able to get SSL working. I successfully binded to port 443. I get to the login page with no issue, and it no longer issues SSL errors, but for some reason, I get the following error when I input the admin username and password and attempt to login:

cURL error 7: failed to connect to 192.168.1.170 port 8080: No route to host

#2

Hi,
let’s take a look at all your parameters to see if there’s something that might be wrong,
tell me your internal and external url and are you using a reverse proxy?

1 Like
#3

Hi @rodgeralley86 once again,
could you tell me your Pydio Cells Version please,
as of now there is a 1.5.0 release that requires no php whatsoever.

1 Like
#4

That may be it. My guy must have followed an old instructional when installing Pydio. It’s version 1.0.1. Is an upgrade difficult from this version to the most recent release? When I run ./cells update, I get the following error.

image

#5

@zayn the upgrade wasn’t too difficult. I just grabbed the new binary, and installed. Had to run the installer twice, and remove the “self: true” part of the pydio.json file again, and my SSL worked perfectly, and the logins went through and I’m able to use Pydio again.

Thank you for the suggestion. I guess I just assumed (which we both know what that makes me) the most recent version was installed. My bad on not looking at that.

#6

Hi,
perfect i’m glad that everything is good.
if you need advices do not hesitate.

Regards

closed #7