Public sharing in 8.2 broken

linux
php70

#1

Running 8.0.2 which is an upgrade from 7, but that was upgraded from many previous versions. Here’s what it looks like when I try to share.

public-share-bug

It’s running from a subdomain, but Pydio is still installed at the root of the public_html folder. The only other relevant thing I can think of is the fact that the document root is above the web root (but I’ve always had it like this).

Here is the content of .htaccess

<IfModule mod_rewrite.c>
# You must set the correct values here if you want
# to enable webDAV sharing. The values assume that your 
# Pydio installation is at http://yourdomain/
# and that you want the webDAV shares to be accessible via 
# http://yourdomain/shares/repository_id/
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php [L]

#Following lines seem to be necessary if PHP is working
#with apache as CGI or FCGI. Just remove the #
#See http://doc.tiki.org/WebDAV#Note_about_Apache_with_PHP_as_fcgi_or_cgi

#RewriteCond %{HTTP:Authorization} ^(.*)
#RewriteRule ^(.*) - [E=HTTP_AUTHORIZATION:%1]

#Following lines may be necessary for a PHP-FPM setup
# to make sure that authorization is transmitted.
# Just remove the # at the beginning of the line

#SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1

</IfModule>

AddType application/json .json

#2

@charles - looks like the message finally showed up.

The other screenshots I wanted to show are:

image

image

Is there anything else I can provide that will help?


#3

Hi,
could you look at your error log, you can find it in the database under this table ajxp_log.
and look at events that happens when you click on the enable public link.

by the way if you want to change the error log


you can do it go to Application parameters > – Loggers


#4

Hi @zayn - this is what I get:


#5

sorry to bother you again as you can see the action.share line is the important one could try to copy the entire stack,
if you want you can do as i said above to get the logs in a file.
I


#6

No bother - I appreciate the help. This is all I get in the text log:

03-08-18 11:00:51 172.16.13.70 INFO ajones conf.sql Switch Repository rep. id=ajxp_home
03-08-18 11:00:55 172.16.13.70 INFO ajones conf.sql Switch Repository rep. id=e99aeadc11d0b50647652ace557fabc9
03-08-18 11:00:56 172.16.13.70 INFO ajones conf.sql Switch Repository rep. id=e99aeadc11d0b50647652ace557fabc9
03-08-18 11:01:14 172.16.13.70 INFO ajones Pydio\Core\Services\RepositoryService Create Repository repo_name=Public
03-08-18 11:01:14 172.16.13.70 INFO c3d13ccaa363 Pydio\Core\Services\UsersService Create User user_id=c3d13ccaa363
03-08-18 11:01:14 172.16.13.70 INFO c3d13ccaa363 action.share New Share file=’/PROJECTS/USACE - Everglades/Public’;files=/PROJECTS/USACE - Everglades/Public;repo_uuid=e99aeadc11d0b50647652ace557fabc9;shared_repo_uuid=b0406d285e38fd109b2778b7b5919583

#7

i don’t see any weird errors,
look at mine and it gives me the link afterwards (screenshot)
if you have admin rights could you go to the sharing panel on the workspaces here’s a screen illustrating that.

edit : my example is using a file but i did test with a repo and it works aswell.


#8

i think i might see, do you have admin access, it could be sharing rights that’s why it doesn’t let you create the public link.
if you could try with an admin account and see if the issue is still here.


#9

Thanks @zayn - I am using an admin account.

I believe it’s an issue with the changes to sharing in v8. Everything used to work fine.Is there something different that needs to be done when upgrading from an old version? Maybe there is a new limitation on sharing files outside the web root that wasn’t there in v7?


#10

hi @adrianbj no there was not such limitations.
Can you maybe open your web developer console (in your browser), clear all in console and network, and observe if there are any errors displayed when you click on the “share” checkbox?
Charles


#11

Hi @charles - no JS errors. Network shows all 200 responses. Is there anything else I can provide?

[]

<?xml version="1.0" encoding="UTF-8"?><tree filename="/" text="" is_file="true" ajxp_im_time="1520529958"><tree is_file="false" filename="/PROJECTS/USACE - Everglades/Public" mimestring_id="8" icon="folder.png" fonticon="folder" openicon="folder_open.png" ajxp_mime="ajxp_folder" file_group="1" file_owner="1" ajxp_readonly="false" file_perms="0777" ajxp_modiftime="1513268736" bytesize="0" ajxp_relativetime="on December, 14th 2017" ajxp_description="Modified on December, 14th 2017" mimestring="Directory" text="Public" ajxp_im_time="1520529958"/></tree>

<?xml version="1.0" encoding="UTF-8"?><tree ><reload_shared_elements/><taskList><![CDATA[ [] ]]></taskList></tree>

<?xml version="1.0" encoding="UTF-8"?><tree ><taskList><![CDATA[ [] ]]></taskList></tree>


#12

Hi @charles - is there anything else I can provide that might help to debug this?

Thanks!


#13

Hi,

I got this error too.

How many authentication driver have you?

I used only the master driver with LDAP and I can’t create public link. Then I configured the DB Authentication in “Secondary driver” and the public link works.

I hope that help.

Malcolm


#14

Hi @Malcolmp - thanks for the input. I only have the primary driver setup, but it’s the DB one. I am assuming public sharing won’t work with LDAP and that’s why you needed to add the DB one as the secondary. I don’t think it will help in my case. For the fun of it I did try to add DB as the secondary as well with no luck.

Thanks anyway!


#15

Ok, well I ended up having to install completely from scratch. Even a reinstall with the old database didn’t work, so I assume there was some db incompatibility issue.