S3 Storage on Cells - Can't connect to Scaleway (missing region)

s3

#1

Im Trying to add an S3 Compatible Object Storage from scaleway.com - to my freshly installed and latest Cells Server on Cent OS 7.4 - but the S3 connection won’t work.

I think that because the region is not specified. How do I specify it ? There is no option in the interface for it.

scaleway endpoint:
s3.nl-ams.scw.cloud

region:
nl-ams


#2

Anyone ?
How to connect the S3-Compatible Storage (from Scaleway) specifying the region
Server: “Cells Home 1.2.5” on Cent OS 7.4.

The standard way through web-interface doesn’t allow to specify the region, which might be the reason of ERROR “Cannot connect to storage” on backend.


#3

Hi,
could you tell me what fields did you use on the web interface to make the connection?


#4

Thank you for replying. Please check the attached screenshots.
My steps were : add the Data Source, then the workspace. When adding the workspace there is a loading icon constantly loading but the storage still remains unusable.
Datasource add:

These errors I see on backend when I SSH to server and start the pydio

ERROR   pydio.grpc.data.sync.***        Could not run   {"error": "objects not reachable"}
ERROR   Could not find DataSource ***   {"currentSources": ["cellsdata", "personal", "pydiods1"]}
ERROR   pydio.rest.tree Rest Error 404  {"error": "Could not find DataSource ***"}

Just to note: my Scaleway Bucket is accessible, Api key/secret is fine, connection to bucket works fine, >> checked it with direct connection aws-cli and other clients.


#5

On Scaleway advised to connect through https … so I tried that, but tried to connect without too, and tried with specifying the port. My guess is that the unspecified region " nl-ams" is the problem.
Here is an old Tutorial released by Scaleway for how to connect to old pydio server. But for “Pydio Cells” is not relevant…
https://www.scaleway.com/docs/deploy-pydio-with-object-storage/

On scaleway the connection details for object storage are:
endpoint: s3.nl-ams.scw.cloud
region: nl-ams

Here is the workspace screen (selecting that Scaleway datasource):


#6

Hi,
yeah your settings seem to be right,
i"ll ask around if theres something possible to do, (maybe add the region manually).


#7

Hi,
sorry if did not attend your issue,
for the moment i could not test with scaleway (we don’t have a bucket on that platform).