Pydio Cells S3 "objects down"


#1

I’m setting up an S3 backend but it gives the status message of Objects down with no clear indication as to what that means. I’ve investigated >1 S3 provider and checked the credentials and they are correct. The only hint in the container logs is this, when I hit the Re-synchronize button:

cells_1  | 2018-10-31T20:21:44.635Z	INFO	pydio.rest.config	Retrieved datasource [aws]	{"datasource": "Name:\"aws\" StorageType:S3 StorageConfiguration:<key:\"customEndpoint\" value:\"\" > ObjectsServiceName:\"gateway3\" ObjectsPort:44191 ObjectsBucket:\"redacted\" ObjectsBaseFolder:\"test\" ApiKey:\"redacted\" ApiSecret:\"redacted\" VersioningPolicyName:\"regular-pruning\" "}
...
cells_1  | 2018-10-31T20:19:51.825Z	ERROR	pydio.grpc.tasks	cannot run action actions.cmd.resync: {"id":"","code":0,"detail":"unknown service \u003cnil\u003e","status":""}

It isn’t really clear to me what the matter is but the instructions (https://pydio.com/en/docs/cells/v1/managing-datasources) seemed easy enough to follow. Am I missing something?


#2

Hi,
you can put your cells in production mode to have more logs or debug mode,
to do so, when you start cells add this./cells start --log=production.


#3

Thanks for that. I specified the environment variable in docker-compose in the end - PYDIO_LOGS_LEVEL=production.

{"level":"error","ts":"2018-11-05T18:44:27Z","logger":"pydio.grpc.data.objects.gateway1","msg":"time=\"2018-11-05T18:44:27Z\" level=fatal msg=\"Unable to initialize gateway layer\" cause=\"Unable to initialize event notification. Get https://s3.nl-ams.scw.cloud/: x509: failed to load system roots and no roots provided\" source=\"[gateway-main.go:357:github.com/pydio/cells/vendor/github.com/pydio/minio-srv/cmd.gatewayMain()]\""}

This reads to me like there is no SSL/TLS CAstore in the container. The container being based on busybox is the root of the problem as it doesn’t contain anything for SSL out of the box. There’s a good stackoverflow post on this here:

I’m going to share the cert store read only from the host as that will fix the problem for now. It would be nice if you took advantage of multistage builds and copied in certs from Debian or Alpine though!


#4

Hi,
can i mark this issue as solved?
it will be helpful if others are looking for the same issue.

Regards


#5

@zayn will work on the offical docker to include the certificates


#6

No, sorry - I’m still having issues but haven’t had time to look at it
much in the last few days.


#7

Hi,
could you tell me what is the exact configuration of your s3 datasource (it’s place in your cells), the provider (amazon, selfhosted with minio, etc…) and is it on the same server where your container runs?
I tried with both a docker container built with the certs(as you showed me with the multistage build) and one without the certs and i did not see the error (i was using minio container which is a s3 self hosting solution on another server) https://www.minio.io/ .
I would like to reproduce your issue to understand it.

regards