Unable to add region for s3 compatible service

#1

Hello,
I’m trying to use the Pydio Enterprise (not Cells) 8.2.3 ovf I downloaded today. I was able to get it running in ESXi 6.7. Where I am running into a problem is the same problem had in previous attempts to use pydio. When adding a s3 compatible workspace, the region selection is a drop down menu that only has AWS regions. It seems like a design oversight. There doesn’t seem to be an option to specify a region for different services. In this case the s3 service is wasabi.com. Is there a way to manually edit the region? I’ve left it blank and used the URI specific to the region but I’m still getting errors. Error message says:
Missing required client configuration options:
region: (string)
A “region” configuration value is required for the “s3” service (e.g., “us-west-2”). A list of available public regions and endpoints can be found at http://docs.aws.amazon.com/general/latest/gr/rande.html.

#2

Hi,
to add a region on pydio 8 you must edit this file plugins/access.s3/manifest.xml, there is a list defined like this key|label,key2|label2.
To add your region add it the following way for instance canada|Canada.

Edit: also when you create a workspace with your S3 do not forget to put the endpoint of your s3 if it’s not on amazon.

#3

Thank you Zayn,
I’m using the Pydio 8.2.3 ovf. Where can I find the root login to edit those files? I don’t believe I was asked to create one when I spun it up. Thanks.

#4

Hi,
for the ovf the login informations can be found inside the readme should be in the zip archive along the ovf,

system:
root / PydioVAPP
pydio / PydioVAPP

watch out the default keyboard layout is qwerty.