Problem adding Backblaze or Wasabi as S3-compatible Storage

Hi,

Has anyone successfully used Backblaze’s S3 compatible storage in Pydio Cells? Their B2 cloud storage is S3 API compatible (according to https://www.backblaze.com/blog/backblaze-b2-s3-compatible-api/), but when I try to add it as a datasource, I get the error “Endpoint: does not follow ip address or domain name standards.” and the bucket list shows “No buckets found”.

This problem is easily replicable by signing up at https://www.backblaze.com/b2/sign-up.html and using the free 10GB to create a bucket + app key, and trying to add the datasource to Cells. Cells public demo gives the same error as my own installation.

I’d appreciate any ideas on how to troubleshoot this further. I’m running Pydio 2.1.5 under Docker.

Edit: I ran into the same problem with Wasabi.

Hello @Zormal,

I will take a look at this with backblaze, I will come back to you with more details.

@Zormal, Could you tell me which parameters did you use to for the datasource?

Here is a screenshot of how I did it.

Heh… silly user error, it seems. I didn’t include the protocol (https://) in the endpoint URL. using the full https://s3.eu-central-003.backblazeb2.com works.

Thanks a bunch!

This topic was automatically closed 11 days after the last reply. New replies are no longer allowed.