Pydio Cells problems after clean install


#1

Hi There,

I’m new to pydio and have just installed Pydio Cells 1.2.0 on a Rhel 7 server. After installation I encounter some problems I need some help with.

Let’s start with how I have installed the application (disabled SSL because it’s a Staging environment):

./cells install

Welcome to Pydio Cells Home Edition installation
Pydio Cells Home Edition will be configured to run on this machine. Make sure to prepare the following data

  • IPs and ports for binding the webserver to outside world
  • MySQL 5.6+ (or MariaDB equivalent) server access
    Pick your installation mode when you are ready.

:heavy_check_mark: Command line (performed in this terminal)
:heavy_check_mark: localhost:8080
:heavy_check_mark: External Host (used to access this machine from outside world if it differs from Bind Host): pydio.acceptatie.example.com
:heavy_check_mark: Disable SSL (not recommended)

Database Connection

:heavy_check_mark: TCP
:heavy_check_mark: Database Hostname: dbhost
:heavy_check_mark: Database Port: 3306
:heavy_check_mark: Database Name: cells
:heavy_check_mark: Database User: pydio
:heavy_check_mark: Database Password (leave empty if not needed): ************
:heavy_check_mark: Successfully connected to the database

Frontend Configuration

:heavy_check_mark: Admin Login (leave passwords empty if an admin is already created): admin
:heavy_check_mark: Admin Password: ********************
:heavy_check_mark: Confirm Password: ********************

Advanced Settings

:heavy_check_mark: There are some advanced settings for ports and initial data storage. Do you want to edit them: y
:heavy_check_mark: Path to the default datasource: /apps/pydio/data
:heavy_check_mark: OpenIdConnect ClientID (for frontend): cells-front
:heavy_check_mark: OpenIdConnect ClientID (for frontend): CTvdZKKrn28CgjWGS5L1YeS6
:heavy_check_mark: OpenIdConnect Server Port: 37842
:heavy_check_mark: Rest Gateway Port: 39566
:heavy_check_mark: Data Gateway Port: 35312
:heavy_check_mark: WebSocket Port: 43068
:heavy_check_mark: WebDAV Gateway Port: 40463
:heavy_check_mark: WOPI Api Port (for Collabora support): 41443

Performing Installation

2018-10-17T11:55:55.497+0200 INFO Starting installation now {“bindUrl”: “http://localhost:8080”}
:heavy_check_mark: Created main database
:heavy_check_mark: Created default datasources
:heavy_check_mark: Configuration of gateway services
:heavy_check_mark: Creation of logs directory

:heavy_check_mark: Installation Finished: please restart with ‘./cells start’ command

Apache vhost settings:

<VirtualHost *:80>
ServerName pydio . acceptatie. example. com
#May be necessary for API direct accesses
AllowEncodedSlashes On
RewriteEngine On

#Proxy WebSocket
RewriteCond %{HTTP:Upgrade} =websocket [NC]
RewriteRule /(.*) wss://localhost:8080/$1 [P,L]
#Finally simple proxy instruction
ProxyPass “/” “http:// localhost:8080/”
ProxyPassReverse “/” “http ://localhost:8080/”

  • Firts Problem:

After the installation I can login, create files and folders and so on. But When I want to “EDIT” a file I get the following Error Message:

The request signature we calculated does not match the signature you provided.
Check your key and signing method

And I see this log entry in the console:

_time=“2018-10-17T14:11:54+02:00” level=error msg="{“method”:“GET”,“reqURI”:"/io/personal-files/test?response-cache-control=no-cache&response-content-type=text%2Fplain",“header”:{“Accept”:["/"],“Accept-Encoding”:[“gzip, deflate”],“Accept-Language”:[“nl-NL,nl;q=0.9,en-US;q=0.8,en;q=0.7”],“Authorization”:[“AWS4-HMAC-SHA256 Credential=eyJhbGciOiJSUzI1NiIsImtpZCI6IjA4OWFmZDhiMzBiMDBhYzljN2NkNTI1ZDIxMTFiMDAwZjBkYjE3NjgifQ.eyJpc3MiOiJodHRwOi8vMTI3LjAuMC4xOjM3ODQyL2RleCIsInN1YiI6IkNpUmtabU14TURCa09TMDNaV016TFRSa05XUXRPV05pWkMwM1pESmlOelUzWW1VeE1USVNCWEI1WkdsdiIsImF1ZCI6ImNlbGxzLWZyb250IiwiZXhwIjoxNTM5Nzc4ODU5LCJpYXQiOjE1Mzk3NzgyNTksIm5vbmNlIjoiNTZkZDVhZTktYzNiZS00YTcyLWFkOTMtMGM0Y2I1NDNkMzg1IiwiYXRfaGFzaCI6Im1wLUt2YS1vSlp2bmx4QjNDMGNWdmciLCJlbWFpbF92ZXJpZmllZCI6dHJ1ZSwibmFtZSI6ImFkbWluIiwicm9sZXMiOiJST09UX0dST1VQLEFETUlOUyxBRE1JTlMsZGZjMTAwZDktN2VjMy00ZDVkLTljYmQtN2QyYjc1N2JlMTEyIiwiZ3JvdXBwYXRoIjoiLyIsInByb2ZpbGUiOiJhZG1pbiJ9.lDufIzx0wcSxRxO_WEiRc22gzsjVA0wHQlurHhk2NhRH-WJVLIm9xJH_0s9v4_FP-DptAVkddlq101hD5O6W8zHjQMiw5NEJlJAQbvzMMU1wD_BxAhWw5w-LDCs3OwwlLr2DgkAp3W6WfhmIcfJsY8iUlfP4BUDTJHnOYlRhHVZUIzOVkVOIuxrq1WYTApkLS8XB8n3fD4Eelxx9kpfEmwvey-T8bqdcocQ-3t1j9CF2bwhvvzOTkSlvo0NFjIbRgSJ0LYJQeIRXuOcmUV_7EIfJ7iwnEmCnxeTc8qoiEpkAfpLjjaGBE_zbro5_oXp8mZYuIm4WtOGPfps5zP2xHw/20181017/us-east-1/s3/aws4_request, SignedHeaders=host;x-amz-content-sha256;x-amz-date;x-amz-user-agent, Signature=179c89e1036e4371b5cc165423dc841008895c88cd1bc6c9e73a6c14bad3431e”],“Cookie”:["_ga=GA1.2.1585868488.1532430119; ga=GA1.3.1585868488.1532430119"],“Host”:[“localhost:8080”],“Referer”:[“http ://pydio.acceptatie.example.com/ws-personal-files/”],“User-Agent”:[“Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36”],“X-Amz-Content-Sha256”:[“e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855”],“X-Amz-Date”:[“20181017T121154Z”],“X-Amz-User-Agent”:[“aws-sdk-js/2.268.1 callback”],“X-Backend”:[“2”],“X-Forwarded-For”:[“127.0.0.1”],“X-Forwarded-Host”:[“pydio. acceptatie. example. com”],“X-Forwarded-Proto”:[“http”],“X-Forwarded-Server”:[“pydio. acceptatie. example. com”],“X-Pydio-Bearer”:[“eyJhbGciOiJSUzI1NiIsImtpZCI6IjA4OWFmZDhiMzBiMDBhYzljN2NkNTI1ZDIxMTFiMDAwZjBkYjE3NjgifQ.eyJpc3MiOiJodHRwOi8vMTI3LjAuMC4xOjM3ODQyL2RleCIsInN1YiI6IkNpUmtabU14TURCa09TMDNaV016TFRSa05XUXRPV05pWkMwM1pESmlOelUzWW1VeE1USVNCWEI1WkdsdiIsImF1ZCI6ImNlbGxzLWZyb250IiwiZXhwIjoxNTM5Nzc4ODU5LCJpYXQiOjE1Mzk3NzgyNTksIm5vbmNlIjoiNTZkZDVhZTktYzNiZS00YTcyLWFkOTMtMGM0Y2I1NDNkMzg1IiwiYXRfaGFzaCI6Im1wLUt2YS1vSlp2bmx4QjNDMGNWdmciLCJlbWFpbF92ZXJpZmllZCI6dHJ1ZSwibmFtZSI6ImFkbWluIiwicm9sZXMiOiJST09UX0dST1VQLEFETUlOUyxBRE1JTlMsZGZjMTAwZDktN2VjMy00ZDVkLTljYmQtN2QyYjc1N2JlMTEyIiwiZ3JvdXBwYXRoIjoiLyIsInByb2ZpbGUiOiJhZG1pbiJ9.lDufIzx0wcSxRxO_WEiRc22gzsjVA0wHQlurHhk2NhRH-WJVLIm9xJH_0s9v4_FP-DptAVkddlq101hD5O6W8zHjQMiw5NEJlJAQbvzMMU1wD_BxAhWw5w-LDCs3OwwlLr2DgkAp3W6WfhmIcfJsY8iUlfP4BUDTJHnOYlRhHVZUIzOVkVOIuxrq1WYTApkLS8XB8n3fD4Eelxx9kpfEmwvey-T8bqdcocQ-3t1j9CF2bwhvvzOTkSlvo0NFjIbRgSJ0LYJQeIRXuOcmUV_7EIfJ7iwnEmCnxeTc8qoiEpkAfpLjjaGBE_zbro5_oXp8mZYuIm4WtOGPfps5zP2xHw”],“X-Real-Ip”:[“127.0.0.1”]}}" cause=“Signature does not match” source="[gateway-pydio-handlers.go:71:github.com/pydio/cells/vendor/github.com/pydio/minio-srv/cmd.gatewayPydioAPIHandlers.GetObjectHandler()]

  • Second Problem:

If I go to settings -> Backends -> Services. All values of the services points to the eth0 ip address. This needs to Change to the eth1 ip address. How do I change those settings? because it is not possible to change anything there.

I have found this on the forum:

In the Configuration Panel, all the endpoints are defined using the public address of the cells instance as base URL (i.e https:// my- public .pydio.com/io for the S3 endpoint). As the bug seems S3 related, I changed this endpoint configuration to use the internal IP address.

On version 1.0.4 this was possible to do. But I cannot change anything in the latest version 1.2.0

I hope someone can help met with the problems. If I have given too little information. Please let me know.


#2

Hi,
try to make sure that you reverse proxy proxies to your external host:

change this, replace the localhosts with what you have on the parameter quoted above.


#3

Hi Zayn,

If I do that what you recommend I get the following error:

404 Site pydio.acceptatie.example.com:8080 is not served on this interface

And I see this in the console:

2018-10-18T10:18:36.812+0200 INFO [INFO] pydio.acceptatie. example. com - No such site at :8080 (Remote: 10.100.114.43, Referer: )
2018-10-18T10:18:37.340+0200 INFO [INFO] pydio.acceptatie. example. com - No such site at :8080 (Remote: 10.100.114.43, Referer: http://pydio.acceptatie. example. com/)
2018-10-18T10:19:10.002+0200 INFO [INFO] pydio.acceptatie .example. com - No such site at :8080 (Remote: 127.0.0.1, Referer: )


#4

Hi,
without the port put the same exact parameter that you have here


#5

Hi Zayn,

I get a proxypass error If I remove the ports:

[Thu Oct 18 11:10:49.692229 2018] [proxy:debug] [pid 16815] proxy_util.c(2426): [client 10.100.114.43:52400] AH00947: connected / to pydio. acceptatie. example. com:80
[Thu Oct 18 11:10:49.692257 2018] [proxy:debug] [pid 16815] proxy_util.c(2802): AH02824: HTTP: connection established with 10.100.114.43:80 (pydio. acceptatie. example. com)
[Thu Oct 18 11:10:49.692264 2018] [proxy:debug] [pid 16815] proxy_util.c(2942): AH00962: HTTP: connection complete to 10.100.114.43:80 (pydio. acceptatie. example. com)
[Thu Oct 18 11:10:49.692399 2018] [authz_core:debug] [pid 17275] mod_authz_core.c(835): [client 10.100.114.43:52402] AH01628: authorization result: granted (no directives)
[Thu Oct 18 11:10:49.692424 2018] [proxy:debug] [pid 17275] mod_proxy.c(1123): [client 10.100.114.43:52402] AH01143: Running scheme http handler (attempt 0)
[Thu Oct 18 11:10:49.692428 2018] [proxy_ajp:debug] [pid 17275] mod_proxy_ajp.c(722): [client 10.100.114.43:52402] AH00894: declining URL http:// pydio. acceptatie. example. com/
[Thu Oct 18 11:10:49.692431 2018] [proxy_fcgi:debug] [pid 17275] mod_proxy_fcgi.c(972): [client 10.100.114.43:52402] AH01076: url: http:// pydio. acceptatie. example. com/ proxyname: (null) proxyport: 0
[Thu Oct 18 11:10:49.692443 2018] [proxy_fcgi:debug] [pid 17275] mod_proxy_fcgi.c(975): [client 10.100.114.43:52402] AH01077: declining URL http:// pydio. acceptatie. example. com/

image


#6

mmm,
can you access your cells without the proxy, lets check this step by step untill we figure out what we need to do.


#7

Yes I can access cells without the proxy. I can also create and edit files without any error If i bypass the proxy.


#8

Hi,
ok so now we isolated one side we know that the proxy config is what we should be focused on then.


#9

The easiest way would be to have the same host for both,

for instance,
Bind host localhost:8080 -> to pydio.acceptatie.example.com:8080
Exte host pydio.acceptatie.example.com:8080
but to access the server you would have to go to http://pydio.acceptatie.example.com:8080 because you need the external host and the right port (which in this case is 8080) and in your reverse proxy config change this,

change all localhost:8080 to --> pydio.acceptatie.example.com:8080.


#10

Hi Zayn,

The application won’t start If I change the Bind Host to a URL:8080 instead of ip:8080.

Then I get the following error during startup cells:

2018-10-22T13:34:26.780+0200 ERROR pydio.grpc.gateway.proxy Could not run {“error”: “cannot create storage without CA URL”}


#11

Hi,
yes my bad i totally forgot that this case is for let’s encrypt or/and when you have a valid domain name(that can be resolved by the DNS).
Mmm lets take this with a simpler configuration.
Can you go for bind <server-ip>:<port>
and external <server-ip>:<port>.

Then in your reverse proxy, make it proxy to this :


#12

Hi Zayn,

I think you have forgot to mention the values :wink:


#13

Hi Zayn,

Can you provide me the correct values? They are empty.

Dave


#14

Hi,
sorry i just noticed that i failed my markdown and therefore the values were not displayed, could you look back at my previous message i fixed it.


#15

This one is still missing the values


#16

so
bind: server ip + port
external : server ip + port
let’s try this config then in the reverse proxy you can proxy to server ip + port and this should be working.


#17

Ok I got this config right now.

pydio.json:

“defaults”: {
“database”: “3e053617d0514ac9a7893aa05f3f56d674343867”,
“datasource”: “pydiods1”,
“url”: “http://10.100.114.43:8080”,
“urlInternal”: “http://10.100.114.43:8080

Apache config:

<VirtualHost :80>
ServerName pydio.acceptatie.example.com
#May be necessary for API direct accesses
AllowEncodedSlashes On
RewriteEngine On
#Proxy WebSocket
RewriteCond %{HTTP:Upgrade} =websocket [NC]
RewriteRule /(.
) ws://10.100.114.43:8080/$1 [P,L]
#Finally simple proxy instruction
ProxyPass “/” “http://10.100.114.43:8080/
ProxyPassReverse “/” “http://10.100.114.43:8080/

If I open the url in the browser it freezes on the “loading” screen:
image

Error log Apache:

[Fri Oct 26 11:45:58.531474 2018] [authz_core:debug] [pid 14711] mod_authz_core.c(835): [client 127.0.0.1:43634] AH01628: authorization result: granted (no directives)
[Fri Oct 26 11:45:58.531558 2018] [proxy:debug] [pid 14711] mod_proxy.c(1123): [client 127.0.0.1:43634] AH01143: Running scheme http handler (attempt 0)
[Fri Oct 26 11:45:58.531568 2018] [proxy_ajp:debug] [pid 14711] mod_proxy_ajp.c(722): [client 127.0.0.1:43634] AH00894: declining URL http://10.100.114.43:8080/login
[Fri Oct 26 11:45:58.531575 2018] [proxy_fcgi:debug] [pid 14711] mod_proxy_fcgi.c(972): [client 127.0.0.1:43634] AH01076: url: http://10.100.114.43:8080/login proxyname: (null) proxyport: 0
[Fri Oct 26 11:45:58.531578 2018] [proxy_fcgi:debug] [pid 14711] mod_proxy_fcgi.c(975): [client 127.0.0.1:43634] AH01077: declining URL http://10.100.114.43:8080/login
[Fri Oct 26 11:45:58.531583 2018] [proxy:debug] [pid 14711] proxy_util.c(1963): AH00933: HTTP: too soon to retry worker for (10.100.114.43)
[Fri Oct 26 11:45:58.531587 2018] [proxy:error] [pid 14711] AH00940: HTTP: disabled connection for (10.100.114.43)
[Fri Oct 26 11:45:59.094742 2018] [authz_core:debug] [pid 14714] mod_authz_core.c(835): [client 127.0.0.1:43636] AH01628: authorization result: granted (no directives), referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.094892 2018] [proxy:debug] [pid 14714] mod_proxy.c(1123): [client 127.0.0.1:43636] AH01143: Running scheme http handler (attempt 0), referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.094911 2018] [proxy_ajp:debug] [pid 14714] mod_proxy_ajp.c(722): [client 127.0.0.1:43636] AH00894: declining URL http://10.100.114.43:8080/favicon.ico, referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.094923 2018] [proxy_fcgi:debug] [pid 14714] mod_proxy_fcgi.c(972): [client 127.0.0.1:43636] AH01076: url: http://10.100.114.43:8080/favicon.ico proxyname: (null) proxyport: 0, referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.094927 2018] [proxy_fcgi:debug] [pid 14714] mod_proxy_fcgi.c(975): [client 127.0.0.1:43636] AH01077: declining URL http://10.100.114.43:8080/favicon.ico, referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.094935 2018] [proxy:debug] [pid 14714] proxy_util.c(2203): AH00942: HTTP: has acquired connection for (10.100.114.43)
[Fri Oct 26 11:45:59.094942 2018] [proxy:debug] [pid 14714] proxy_util.c(2256): [client 127.0.0.1:43636] AH00944: connecting http://10.100.114.43:8080/favicon.ico to 10.100.114.43:8080, referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.095008 2018] [proxy:debug] [pid 14714] proxy_util.c(2426): [client 127.0.0.1:43636] AH00947: connected /favicon.ico to 10.100.114.43:8080, referer: http://pydio.acceptatie.example.com/login
[Fri Oct 26 11:45:59.095069 2018] [proxy:debug] [pid 14714] proxy_util.c(2802): AH02824: HTTP: connection established with 10.100.114.43:8080 (10.100.114.43)
[Fri Oct 26 11:45:59.095084 2018] [proxy:debug] [pid 14714] proxy_util.c(2942): AH00962: HTTP: connection complete to 10.100.114.43:8080 (10.100.114.43)
[Fri Oct 26 11:46:00.195399 2018] [proxy:debug] [pid 14714] proxy_util.c(2218): AH00943: http: has released connection for (10.100.114.43)


#18

Hi,
the freezing loading screen is because the external url is not matching the proxy url,
to fix that change this with the proxy url:

for instance if your proxy address is pydio.acceptatie.example.com then the external url should also be this pydio.acceptatie.example.com.

To resume what i said above,
bind url : is the server address where cells is located;
external url: is the url to access cells, it should be the same as the reverse proxy url because you are accessing cells through the proxy so it has to be authorized.


#19

Ok I now got the following config in cells:

“defaults”: {
“database”: “3e053617d0514ac9a7893aa05f3f56d674343867”,
“datasource”: “pydiods1”,
“url”: “http://pydio.acceptatie.example.com”,
“urlInternal”: “http://10.100.114.43:8080

config in apache:

<VirtualHost :80>
ServerName pydio.acceptatie.politie.nl
AllowEncodedSlashes On
RewriteEngine On
#Proxy WebSocket
RewriteCond %{HTTP:Upgrade} =websocket [NC]
RewriteRule /(.
) ws://10.100.114.43:8080/$1 [P,L]
#Finally simple proxy instruction
ProxyPass “/” “http://10.100.114.43:8080/
ProxyPassReverse “/” “http://10.100.114.43:8080/

Now I get the same error like I mentioned in my first post when I want to edit a file:

And I see this on the console:

2018-10-26T16:01:45.119+0200 INFO pydio.grpc.data.sync.personal CreateNode {“node”: “Uuid:“c7fb946c-6243-4c54-855e-85e0d1bbb66b” Path:“admin/test.txt” Type:LEAF Size:1 MTime:1540562503 Mode:511 Etag:“7215ee9c7d9dc229d2921a40e899ec5f” “}
time=“2018-10-26T16:01:46+02:00” level=error msg=”{“method”:“GET”,“reqURI”:”/io/personal-files/test.txt?response-cache-control=no-cache&response-content-type=text%2Fplain",“header”:{“Accept”:["/"],“Accept-Encoding”:[“gzip, deflate”],“Accept-Language”:[“nl-NL,nl;q=0.9,en-US;q=0.8,en;q=0.7”],“Authorization”:[“AWS4-HMAC-SHA256 Credential=eyJhbGciOiJSUzI1NiIsImtpZCI6IjhmMzNmNmI4OTAyZWViMTMzMjM0NWZkMDU2MDFlNTM3YmViMGNhODUifQ.eyJpc3MiOiJodHRwOi8vMTI3LjAuMC4xOjM4NDc0L2RleCIsInN1YiI6IkNpUTFaRGcxT1daa015MWhZV1ptTFRSaU1EWXRPVFZqWVMxbE1UTmlPVEV5WVdaaU5UTVNCWEI1WkdsdiIsImF1ZCI6ImNlbGxzLWZyb250IiwiZXhwIjoxNTQwNTYzMDkyLCJpYXQiOjE1NDA1NjI0OTIsIm5vbmNlIjoiZTE2ZTJmYWUtMDQ3Ny00N2FmLWI0MGQtMzk1Y2MxZjA2OWFlIiwiYXRfaGFzaCI6IkJBNlExcFFKUks3dWhGMVZSNkRVY1EiLCJlbWFpbF92ZXJpZmllZCI6dHJ1ZSwibmFtZSI6ImFkbWluIiwicm9sZXMiOiJST09UX0dST1VQLEFETUlOUyxBRE1JTlMsNWQ4NTlmZDMtYWFmZi00YjA2LTk1Y2EtZTEzYjkxMmFmYjUzIiwiZ3JvdXBwYXRoIjoiLyIsInByb2ZpbGUiOiJhZG1pbiJ9.MjPCG4o3cJwgi9BCVHvaa72DJkOYkwrvhwXFerQtOYi0p-8_QUsecFQ2ZM86a5F7g44-4Z4PDZeKxV8_ypL-vUw5rvqPT7ceLegSRO3wzVg7TroX2TMFOsJag1BdXia1hOzcOmTZGsdZ9oecQMHYKjPwcPdHa8R8Anm03w2a4Sk8M7GaKeV_BTkYyfFcVMmiR5C_gGxMDguUVIY-HpIs1aU9U64oxW5gGgvEUzHP1Ikt_AtE9lFN0Ozp8Cf77oyvD6Q3FXBELpXXJfnpNkyXxxcyzP7dSO0Rfa2j_IWWZlvtpZoWJYNWmuHGEooESeyupMoKYa3AwSd8JcLX0YSgTQ/20181026/us-east-1/s3/aws4_request, SignedHeaders=host;x-amz-content-sha256;x-amz-date;x-amz-user-agent, Signature=c98c65ae9a7b2ac8625515cc851b81c48ae62672236f2a3a97f94b91a7ada972”],“Cookie”:["_ga=GA1.2.1585868488.1532430119; _ga=GA1.3.1585868488.1532430119"],“Host”:[“10.100.114.43:8080”],“Referer”:[“http://pydio.acceptatie.example.com/ws-personal-files/"],“User-Agent”:["Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36”],“X-Amz-Content-Sha256”:[“e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855”],“X-Amz-Date”:[“20181026T140146Z”],“X-Amz-User-Agent”:[“aws-sdk-js/2.268.1 callback”],“X-Forwarded-For”:[“10.100.114.43”],“X-Forwarded-Host”:[“pydio.acceptatie.example.com”],“X-Forwarded-Proto”:[“http”],“X-Forwarded-Server”:[“pydio.acceptatie.example.com”],“X-Pydio-Bearer”:[“eyJhbGciOiJSUzI1NiIsImtpZCI6IjhmMzNmNmI4OTAyZWViMTMzMjM0NWZkMDU2MDFlNTM3YmViMGNhODUifQ.eyJpc3MiOiJodHRwOi8vMTI3LjAuMC4xOjM4NDc0L2RleCIsInN1YiI6IkNpUTFaRGcxT1daa015MWhZV1ptTFRSaU1EWXRPVFZqWVMxbE1UTmlPVEV5WVdaaU5UTVNCWEI1WkdsdiIsImF1ZCI6ImNlbGxzLWZyb250IiwiZXhwIjoxNTQwNTYzMDkyLCJpYXQiOjE1NDA1NjI0OTIsIm5vbmNlIjoiZTE2ZTJmYWUtMDQ3Ny00N2FmLWI0MGQtMzk1Y2MxZjA2OWFlIiwiYXRfaGFzaCI6IkJBNlExcFFKUks3dWhGMVZSNkRVY1EiLCJlbWFpbF92ZXJpZmllZCI6dHJ1ZSwibmFtZSI6ImFkbWluIiwicm9sZXMiOiJST09UX0dST1VQLEFETUlOUyxBRE1JTlMsNWQ4NTlmZDMtYWFmZi00YjA2LTk1Y2EtZTEzYjkxMmFmYjUzIiwiZ3JvdXBwYXRoIjoiLyIsInByb2ZpbGUiOiJhZG1pbiJ9.MjPCG4o3cJwgi9BCVHvaa72DJkOYkwrvhwXFerQtOYi0p-8_QUsecFQ2ZM86a5F7g44-4Z4PDZeKxV8_ypL-vUw5rvqPT7ceLegSRO3wzVg7TroX2TMFOsJag1BdXia1hOzcOmTZGsdZ9oecQMHYKjPwcPdHa8R8Anm03w2a4Sk8M7GaKeV_BTkYyfFcVMmiR5C_gGxMDguUVIY-HpIs1aU9U64oxW5gGgvEUzHP1Ikt_AtE9lFN0Ozp8Cf77oyvD6Q3FXBELpXXJfnpNkyXxxcyzP7dSO0Rfa2j_IWWZlvtpZoWJYNWmuHGEooESeyupMoKYa3AwSd8JcLX0YSgTQ”],“X-Real-Ip”:[“10.100.114.43”]}}" cause=“Signature does not match” source="[gateway-pydio-handlers.go:71:github.com/pydio/cells/vendor/github.com/pydio/minio-srv/cmd.gatewayPydioAPIHandlers.GetObjectHandler()]"


#20

Hi,
so we are now back at where we started, mmm i thought that the usage of the ip would fix that.
I’m going to do some testing of my own and will get back to you when i stumble upon something.

This must be related to the reverse proxy, because it adds a new layer it might be messing things up.