Pydio Cells : cannot delete files anymore


#1

Hello,

I’m running Pydio Cells on Centos 7.4 (on which I updated the ca-certificates package)

After having been away for a couple of weeks, I’ve been trying to delete files from any of a set of workspaces I configured. This fails and displays a popup with an error message, which is also generated in the log file :

AWS HTTP error: cURL error 60: Peer certificate cannot be authenticated with given CA certificates {“FrontIp”: “_xxx.yyy.zzz.tt_t”, “UserId”: “foobar”, “WorkspaceId”: “0456d85068159a763d616009268fa7db”, “Source”: “StreamWrapper.php l.738”, “Nodes”: []}

Did anyone encounter the same issue, and managed to fix it ?

Many thanks for any clues for solving this problem.


#2

Hi,
So the php front cannot connect to the backend anymore, due to certificates issues. You may have to tweak the http://php.net/manual/en/curl.configuration.php#ini.curl.cainfo settings so that curl can find the correct certificates.
How did you configure cells for ssl exactly ?
Charles


#3

Thank you for your reply Charles.

I did not change the configuration settings for the communication protocols, so I didn’t configure Cells for SSL. Moreover, as there is no system-wide PHP installation on the machine that is hosting Cells, there is no php.ini to customize. I checked in the cells installation directory tree, and the only php.ini file is located here :

.config/pydio/cells/static/pydio/plugins/cache.doctrine/vendor/doctrine/cache/tests/travis/php.ini

which doesn’t look as a location that might globally be used by cells.

After further investigating, I suspect the problem might be related to the fact that Cells is served by a (Reverse)Proxy hosting several (non Cells related) domains, some of which have, since a couple of weeks, their own certificates and use SSL. But I’m still puzzled by the potential interference with the Cells front-end / back-end communicatons.

Mark