Pydio 8 background task not working

Issue : I cannot do any actions (eg. Move, Delete…etc) on files larger than 10MB. Background task notification will be shown but nothing happened. (eg. Delete file larger than 10MB, background task running, after 1 day, still running)


  • I have no problem with files under 10MB.

  • I am using apc cache and discovered Cache Health > 60% (I think this is bad)

  • Based on Diagnostics :
    Client : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.186 Safari/537.36
    Crypto Extension Detected : OpenSSL
    Command Line Available : No :
    DOM Enabled : Yes
    Exif Enabled : Yes
    GD Enabled : Yes
    Upload Max Size : 1G
    Memory Limit : 256M
    Max execution time : 300
    Safe Mode : 0
    Safe Mode GID : 0
    Xml parser enabled : 1
    Server OS : Linux
    Session Save Path : /opt/alt/php70/var/lib/php/session
    Session Save Path Writeable : Yes
    PHP Version : 7.0.27
    Locale : C
    Directory Separator : /
    PHP Opcode Cache extension loaded : Yes
    PHP INTL extension loaded : Yes
    PHP Output Buffer disabled : Yes
    PHP File Uploads enabled : Yes
    Magic quotes disabled : Yes
    Upload Tmp Dir Writeable : Yes
    PHP Upload Max Size : 1073741824
    PHP Post Max Size : 134217728
    Users enabled : Yes
    Guest enabled : No
    Writeable Folders : [cache:true,
    Zlib Enabled : Yes

sorry for the late response i believe that for background tasks you need the command line and as i can see in your config it’s disabled could you try to enable it and try again with large files.

Is it enabled here within Application Core?


i’m at loss because on your php it says that it’s not enabled.

But yes it’s the right place to enable it,
now you have to enabled on the php end too.

edit : you need php cli.

I’m under a shared hosting, and has no accessibility to the root.

However, after asking the help from my hosting server. They told me that PHP CLI has already been enabled for PHP70 which I am using.

sometimes you need add the full path for php

as seen in your screen the command that calls php should php but it could be different on your setup
if you’re on a linux server use which php.

Sorry for the late reply.

It seems the directory was the problem.
After placing the correct directory, diagnostics show Command-Line was enabled.

Background task now works properly.

Thank You very much for your help and patience!