Background Tasks not working

centos

#1

I’m not having any luck getting background tasks to run. I have recently upgraded to Pydio 8.02, which didn’t fix the problem.

I have confirmed CLI is enabled and working.

Regardless, handling of files over 10Mb require a background task which never completes. The popup appears but no error messages. Diagnostics are all ok.

The main task I’m trying to complete is emptying the Recycle Bin!

Can someone advise where to look. Thanks.

Running on CentOS 7 - cPanel/WHM


#2

Hi! did you try to set the absolute path to php cli in the settings? Or checking the default value is correct for your system?


#3

Hi, Make sure that php-cli use the same (configuration of ) php.ini with php cgi


#4

Hi. Thanks for your reply. Yes, that was one of the first things I did to set the absolute path.
As I said, it’s reporting that CLI is working


#5

Um… I’m not exactly sure what you’re referring to here?


#6

Just wondering if anyone has any further information about this error. It’s been a couple of months and I still don’t have background tasks running successfully.

In particular, deleting files over 10Mb raises a background task - which never runs. My client is unable to Empty Recycle bin or delete files larger than 10Mb due to this.

Everything else appears to be functioning correctly.

Thanks in advance.


#7

I have the same issue here with 8.2.2 on CentOS 7.5.
Background tasks notifies that a background task is launching but actually it will never start.
(nor finish).
This is absolutely required for operation on our end, as we use it as big remote file management tool (not as cloud storage).


#8

Hi,
what did you put for the php-cli here,


in the file did you put your php-cli absolute path ?
you should take a look in the file.


#9

Hello,

I would like to know how do you change the absolute path?

Best.


#10

Hi,

You can set in it conf/conf.core.ajaxplorer.inc or (/etc/pydio/conf.core.ajaxplorere.inc)


Pydio 8.2.2 Cannot delete/move files, how to activate CLI?
#11

Hi c12simple,

Sorry im quite new to this, so if i give the path to the php file location, for eg “C:\ampps\conf\original-php-7.1.ini” will it be sufficient?


#12

Becasue im not sure what path to give, i havent done this before.
can i know what correct directory he mentions here, i tried changing to all mentioned directory possibiliites still no success. maybe im doing it wrong…


#13

Hope this will help out

Client : Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 UBrowser/7.0.185.1002 Safari/537.36
Crypto Extension Detected : OpenSSL
Command Line Available : No :
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 128M
Memory Limit : 128M
Max execution time : 30
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : WINNT
Session Save Path : C:/Program Files/Ampps\tmp
Session Save Path Writeable : Yes
PHP Version : 7.1.2
Locale : C
Directory Separator :
PHP INTL extension loaded : No
PHP Output Buffer disabled : No
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 134217728
PHP Post Max Size : 8388608
Users enabled : Yes
Guest enabled : No
Writeable Folders : [cache:true,
data:true]
Zlib Enabled : Yes

Would appreciate if someone can help me out with this…


#14

Hi @Waseem
In windows, it’s path to php.exe

“Use COM class” : On

Sorry: Use COM class should be ON when you use IIS


#15

hi @c12simple thanks for the reply, ok here’s what i did. reinstalled ampps on the same drive used as the file server. now the files are being copied no matter the size. although the CLI shows as disabled in the diagnostics. will CLI be needed or should i leave the system as it is since it is working alright.

i get indexing running in the background,shows as starting and stays that way, this might be due to the CLI not being enabled, hopefully it wont cause a problem…