Upload big files in pydio8 fails

php71

#1

installed pydio 8.2.1 community edition debian8 linux, with apache webserver, php 7.1

Hello, after erasing an old pydio 8 installation completely , i erased also the database .
i installed a fresh pydio 8.2.1 with a new database ( mysql)

the failure coming up is: i can upload small files, but if i upload bigger files it hangs with a screen telling me “uploading 1 file…” ( lower right corner). if i look in the folder the file is missing.
php settings are ok and adapted to 640MB. the file causing headaches is 400 MB
in the server logs it tells me the following:

2018/09/04 15:16:41 [error] 18823#0: *221241 client intended to send too large body: 446004271 bytes, client: 93.194.69.113, server: shares.xyz.de, request: “POST /pydio/index.php?secure_token=B6wm0KQEGOSeKXLJWclPrvNMeyPdgP3P&&get_action=upload&xhr_uploader=true&dir=%2FTaipan HTTP/1.1”, host: “shares.xyz.de”, referrer: “http://shares.xyz.de/pydio/ws-default/Taipan

here the diagnose output: Client : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36 OPR/55.0.2994.44
Crypto Extension Detected : OpenSSL
Command Line Available : Yes
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 640M
Memory Limit : 512M
Max execution time : 300
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : Linux
Session Save Path : /var/lib/php5/sessions
Session Save Path Writeable : No
PHP Version : 7.1.21
Locale : C
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : Yes
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 671088640
PHP Post Max Size : 671088640
Users enabled : Yes
Guest enabled : No
Writeable Folders : [cache:true,
data:true]
Zlib Enabled : Yes


thanks for help in advance…
tom


#2

Hi,
what are the values in pour php file for those,

  • memory_limit (512)
  • post_max_size (?)
  • upload_max_filesize (640)

#3

Hello Zayn,

the values are as described below.

  I see also a difference between my win10 PC and other PCs i used

to test (Win7)

my pc creates timeouts, the win7 PCs not.

  All three tested with the same upload tool and settings.

sometimes from same router or a neighbour in the street.

thanks Tom


#4

Hi,
could you please tell me what are the values on the menu, Application parameters > Uploaders
in the limitation section.


#5

Yes its nearly 671000.
hope this helps by analyzing it.
sincerely Tom


#6
  • memory_limit (512)
  • post_max_size (640)
  • upload_max_filesize (640)

thanks for taking care. i am wondering the mail response was mot listed here…since a week


#7

Hi,
let’s take this step by step and then we will figure the issue out,
first verify or/and modify the values of your /etc/php/7.1/apache/php.ini file ( if you can put 1G for upload and post and then 256/512M for the memory limit) then do a service apache2 restart,
then log to your pydio go to Application parameters > Uploaders and in the limitation section and put the File size field to 0 save, clear the plugin cache by doing a rm -f <your pydio>/data/cache/plugins_* and lets also add rm -f <your pydio>/data/cache/i18n/*.
After all of this if the issue is still not resolved we will look into further details.


#8

We had similar problems and were able to solve it by using plain values for memory_limit, post_max_size, … and no “G” or “M”, otherwise we were not able to upload any file.

Best,
Markus


#9

i changed it also away from 640M :slight_smile: but no improvement


#10

Hello zayn,
Thanks for the advice.
But i am on a rented server and cannot change all php parms on my own.
The support guys had adapted as i wrote the parms. I changed also the uploaders file size to zero.
I cleared also the cached plugin folder.
But support is not willing to expand the parms above their normal settings.
sincerely tom