Problem with editing documents in Collabora with Pydio Cells

plugins

#1

I’ve setup my docker mysql, pydio, collabora containers this way and after configuring the Collabora plugin I can’t edit documents.

(Run once) docker network create my-network
docker run --rm -d -v z:\docker\mysql:/var/lib/mysql --name mysql-server --network my-network -e MYSQL_ROOT_PASSWORD=secret mysql:5.7
docker run -d -e PYDIO_LOGS_LEVEL=production -e CELLS_EXTERNAL=<IP of docker host>:8080 -e CELLS_BIND=0.0.0.0:8080 -v z:\docker\pydio:/root/.config/pydio/ --name pydio --rm --network my-network -d -p 8080:8080 pydio/cells
docker run -t -d -p 9980:9980 -e "extra_params=-o:ssl.enable=true" --name collab --rm --network my-network collabora/code

I get ther following error on firefox.

Blocked by Content Security Policy

An error occurred during a connection to <IP of docker host>:8080.

Firefox prevented this page from loading in this way because the page has a content security policy that disallows it.

If I try to open the frame in a new window I can see the collabora editor.

In Chrome, I get a blank page where the editor should be.

I also tried setting ssl.enable=false for collabora and disabling SSL option in the collabora plugin but still get the same error.


#2

Hi,
could you tell me what parameters you’ve put for the collabora plugin (inside cells)?


#3

Libre Office SSL: ON
Libre Office Host:172.18.0.4
(The IP of the container by typing: docker inspect collab)
Libre Office Port: 9980