Pydio : Collabora doesn't open documents

hello everyone.

I installed Pydio 8 and collabora online plugin on a Debian 9.5 server.
the container runs correctly, i think and i configured collabora.

But now, when i try to open a document with collabora, it open a frame.
I can see the top menu but it doesn’t open the document in order to modify it.

The menu buttons appear but they don’t work.

Hi,
do you have any log appearing when you try to open a document?
otherwise you could put your pydio in debug mod

Go to conf/bootstrap_context.php .
Switch this line to true : 
define("AJXP_SERVER_DEBUG" , true);

and reproduce the error.

hello, if it can help, i saw this error on the container collabora in portainer
emphasized text
wsd-00030-00040 2019-02-21 07:42:37.258492 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache.| wsd/FileServer.cpp:279

i tried to reproduce the error that you told me to do.
But where i can find the error logs in order to see the error?

You can take a look at your browser’s console, if you enabled the debug mod (don’t forget to disable it back if you are running in production), you could also take a look at your webserver’s logs.

if i understand the log, there is a problem with xframe option.
Content Security Policy: « x-frame-options » ignoré en raison de la directive « frame-ancestors ».

I think that i ve to change the x-fram-options but i don’t find it

I still have an error opening documents.


Every time i try to open a document, i have this error in the frame.

it’s a LAMP server with pydio 8 and the container Collabora in docker.

Hi,
ok i see your settings and you are not running it behind a reverse proxy ?

I use the virtual host example on the guide for collabora.
In this document, i put the ssl self signed and the reverse proxy configuration.

this is my .conf for collabora online

hi,

  1. in .conf file, please add “nocanon” at the end of ProxyPassMatch "/lool/(.*) …127.0.0.1:9980/lool/*1/ws nocanon

  2. (just testing) If pydio is running on a domainName, please try to enter docker collabora, execute following command: echo "ipaddress_of_pydio domainName" >> /etc/resolv.conf

  3. try to output log of collabora: docker logs -f containerID

Thanks for your response and your help.
I ve to make it run but i always block with the collabora installation
i’ve got this at the end

My bad
echo "ipaddress_of_pydio domainName" >> /etc/hosts

enter docker collabora, execute: docker exec -it containerID /bin/bash

I did what you said but nothing have changed.
I tried on different web browser:

  • chrome displays me that error
  • firefox displays the frame with the toolbar but nothing else

I still have this line in the logs :

wsd-00030-00040 2019-03-07 07:45:14.089468 [ websrv_poll ] WRN client - server version mismatch, disabling browser cache.| wsd/FileServer.cpp:279

I don’t know if it’s ok but i ve 3 containers in my docker : collabora online, portainer et watchtower.
I can see the log in portainer web interface and it’s there i saw the error above.

Same here… Followed official Pydio guide to install Collabora, bot documents not being opened. No errors in pydio logs.

Zoho is not working too… is the project abandoned now for good???