Collabora Online - 502

#1

I’m unable to open a document to modify in Pydio Cells using Collabora running on a local docker container. When I attempt, I get a 502 - Bad Gateway. I’m using the docker container name as the libre office host, and its respective port. I’ve tried with ssl on/off.

I’ve followed the steps here, https://pydio.com/en/docs/cells/v1/collabora-online. Is there something I’m missing?

#2

Hi,
If docker is running on the same server, use “localhost” instead of infallible_sinoussi

#3

“localhost” produces a 502 as well.

#4

I noticed the online demo produces this error too when you switch it from open office to collabora.

#5

Hi,
If you want to use the container name you must have your containers both running in the same docker network (you can add them), otherwise you can just use the host ip,
localhost inside a container will always refer to itself as it is the loopback.

#6

I have both containers running in the same docker network, but using the container name in the Collabora Online plugin settings still produces a 502 when I try to open a file.

Below is an inspection of the network. I’m using the ‘pydio_test_collaboracode_1’ name for the Libre Office Host setting.
[
{
“Name”: “pydio_test_default”,
“Id”: “c0f743417f97724f867bdc39209d2399e3e2332c5adcd3d3f1e857c8a24737e2”,
“Created”: “2019-04-22T19:25:55.4624108Z”,
“Scope”: “local”,
“Driver”: “bridge”,
“EnableIPv6”: false,
“IPAM”: {
“Driver”: “default”,
“Options”: null,
“Config”: [
{
“Subnet”: “172.18.0.0/16”,
“Gateway”: “172.18.0.1”
}
]
},
“Internal”: false,
“Attachable”: true,
“Ingress”: false,
“ConfigFrom”: {
“Network”: “”
},
“ConfigOnly”: false,
“Containers”: {
“482b0cdc4938826879fee731574173518ae84bb76408d6bdbc1b0275860f5fff”: {
“Name”: “pydio_test_collaboracode_1”,
“EndpointID”: “f4e1e960a003b8d7b1f8cad2238d9423cbe4e703a3718c9e757a359e9a6ddd6c”,
“MacAddress”: “02:42:ac:12:00:04”,
“IPv4Address”: “172.18.0.4/16”,
“IPv6Address”: “”
},
“66e24d7409a21b90c607a32f71de73b8de1bb8f110657e1a82d9dda9479e44c2”: {
“Name”: “pydio_test_mariadb_1”,
“EndpointID”: “8c885a8002d4c03225c2504361eb2b12b946e1cee604b67eb9bba990fc3c2103”,
“MacAddress”: “02:42:ac:12:00:03”,
“IPv4Address”: “172.18.0.3/16”,
“IPv6Address”: “”
},
“7e7da7b9790658e2295ad88e196c8ae3c7fcee848c9c8f177406d9aacfd7e022”: {
“Name”: “pydio_test_cells_1”,
“EndpointID”: “54e1ad82bd23dad4c57b3d83d76dde4e925801d29e5d17796f2dbd8c9d6fd147”,
“MacAddress”: “02:42:ac:12:00:02”,
“IPv4Address”: “172.18.0.2/16”,
“IPv6Address”: “”
}
},
“Options”: {},
“Labels”: {
“com.docker.compose.network”: “default”,
“com.docker.compose.project”: “pydio_test”,
“com.docker.compose.version”: “1.23.2”
}
}
]

#7

Hi,
could you try with the containers ip, 172.18.x.x also you could make sure that it works by using your host ip.

#8

Using that ip didn’t work.