FolderDownload does not Work after Upgrade

#1

Short Update:
I can only download One Filer per Download downloading 2 Files produce the same error
Only Variables should be assigned by reference

I remove the Plugins and the i118n Folder and still got the error…

I am on 8.2.2 (2018-10-10)
Yesterday I was on 8.0.1

Can you help me ?

Using Windows Server for Pydio

#2

Hi,
could you tell me your exact configuration, php, mysql, os version …,
also could you take a look a the php logs after you try to download the files and see what happens.

Another thing could be to enable the debug mod on your pydio which will help us get a stack of the error,
to do so follow this:

DEBUG MODE PYDIO

Go to conf/bootstrap_context.php .
Switch this line to true : 
define("AJXP_SERVER_DEBUG" , true);
#3

Client : Mozilla/5.0 (Windows NT 10.0; Win64; x64)
AppleWebKit/537.36 (KHTML, like Gecko)
Chrome/72.0.3626.109
Safari/537.36

Crypto Extension Detected : OpenSSL
Command Line Available : No :
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 2048M
Memory Limit : 2048M
Max execution time : 300
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : WINNT (WindowsServer2016)
Session Save Path : C:\inetpub\Temp\sessions
Session Save Path Writeable : Yes
PHP Version : 5.6.30
Locale : German_Germany.1252
Directory Separator :
PHP INTL extension loaded : No
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 2147483648
PHP Post Max Size : 2147483648
Users enabled : Yes
Guest enabled : No
Writeable Folders : [cache:true,
data:true]
Zlib Enabled : Yes

#4

do you think you could update to php 7,
and if possible i would like to take a look at the php logs and the error stack if there is one.

#5

Where do i find the Logs?

Sure i can Update…
After the Fix ?

#6

the logs can be found where your php logs are, usually in the webserver’s error log,
i suggested you to update because pydio 8.2.2 is working better with that version nonetheless i cannot assure you that just updating php will fix the issue.

edit: as for the debug mod it should appear on your browser and console.

#7

Logs are Empty?
php-5.6.30_errors.log are Empty
In my C:Windows/Temp folger are the Zip files created with 0Bytes

I upgrade php now to 7.2.7
Php is on 7.2.7 Got the same Error

#8

10:47:12 Europe/Belgrade] PHP Fatal error: Uncaught Pydio\Core\Exception\ResponseEmissionException: Could not send response! in “Path”\core\src\pydio\Core\Http\Server.php:257
Stack trace:
#0 [internal function]: Pydio\Core\Http\Server->catchError(8, ‘ob_end_flush():…’, ‘C:\inetpub\wwwr…’, 157, Array)
#1 "path"core\src\pydio\Core\Controller\ShutdownScheduler.php(157): ob_end_flush()
#2 [internal function]: Pydio\Core\Controller\ShutdownScheduler->callRegisteredShutdown()
#3 {main}
thrown in “path” core\src\pydio\Core\Http\Server.php on line 257

#9

Ok i do a restore and now i am back to 8.0.1 everything is Working.

#10

Hi,
that’s nice, but it’s weird that the upgrade messed your downloads,
could you do a new save and try to upgrade once again now that you have php 7.