Filename Search not working

#1

I host a site for an not-for-profit organization that only stores training videos. There are no documents on the site, only videos. The video filenames are coded with numbers by type of video.

Obviously since these are video files there is NEVER a need to search for contents in a files, only search by file names.

The filename search is not working: For example when I enter "401*" in the search field I always get a pop-up window at the bottom of the screen that displays "Network error h is null". I also get a spinning progress indicators that never stops…

Currently running 8.2.1 (2018-07-03).

In the Update Engine Screen, 2 upgrades are listed but when I check the box next to the upgrade and click on [START UPDATE] nothing happens.

What can I do to get the filename search function to work?

Client : Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
Crypto Extension Detected : OpenSSL
Command Line Available : No : sh: php: not found
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 500M
Memory Limit : 512M
Max execution time : 120
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : FreeBSD
Session Save Path :
PHP Version : 7.2.16
Locale : C
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : No
PHP Output Buffer disabled : No
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 524288000
PHP Post Max Size : 1048576000
Users enabled : Yes
Guest enabled : No
Writeable Folders : [<b>cache</b>:true,<br> <b>data</b>:true]
Zlib Enabled : Yes

#2

Hi,
did you index the files once uploaded?

#3

Thanks for this help.
I did not do this with previous versions of Ajax Explorer or Pydio.

It has been running for several hours…
“Running indexation in background Starting…”.
Also there is a red throbber circle next to the search box.

How long should this take? I have about 5000 files in the library, many in the personal files workspaces of 8 users. There are also 7 other common workspaces with files from previous years.

Remember that I wrote that these are video files. I only need to search by filename and never by file contents.

UPDATE: Still running after 24 hours…
When I log back in I see
“Running indexation in background Starting…”.

#4

Hi,
did you try to do a research meanwhile ?

#5

Yes I have tried searching for 401* again. Still get the pop-up with error "Network error h is null.

“Index Content” described above has been continually running for 3 days now. When I login and access the “All User Files” workspace is still see:
“Running indexation in background Starting…”. Is this attempting to index contents of the files? My library is video flies only. All I need to search for is filenames. We desperately need to locate files by filename.

#6

Hi,
ok first, could you assure me that you have lucene on the workspace,

Also could you do this,
Debug Mode


Go to conf/bootstrap_context.php .

Switch this line to true : 

define("AJXP_SERVER_DEBUG" , true);

reproduce the error and send the me stack.

#7

Hi,

Maybe you have problem with cli path.
Try to turnoff php cli in Pydio then launch index again.
Note: make sure max_exection_time is longer enough for this process

#8

To aid in testing I have changed to a smaller work space, only 154 Video files…
I have verified that this workspace has "Lucene Search Engine" turned on.

Maybe you have problem with cli path.
Try to turnoff php cli in Pydio then launch index again.

Settings> Application Core> Command Line:
Command-line Active is ON
Command-line PHP only had "php" I have changed this to the full path.
In Diagnostic it now says Command Line Available YES

Now when I re-Index Content, in the pop-up window where it used to only display: Starting… I now see it display that it is indexing subdirectory names in the workspace in turn and appears to complete in less than 60 seconds. However when I enter "404*" into the search box I still get a popup at the bottom center of screen that display "Network error h is null". I know for a fact that there are 6 filenames in the workspace that begin with "404".

I have also set Command-line Active to OFF, results are the same…

Note: make sure max_exection_time is longer enough for this process

In php.ini max_execution_time changed from 120 to 600
Apache restarted to refresh change to php.ini

How long should it take to Index only 154 filenames? 12 core processor with 128GB RAM. find command in shell is almost instantaneous.

#9

conf/bootstrap_context.php edited to:

define(“AJXP_SERVER_DEBUG” , true);

Where do I find the "stack" to send you?

In the Server Logs I see:

#10

Hi,
the error should appear either in your browser webconsole or you’ll see it in the pop-up at the bottom once you have an error.

#11

hi @ls4680

Do you have any error in the log of web server? The difference is you are running pydio on FreeBSD. So if it’s possible, please send me access to your server via tran@pydio.com

#12

Hi c12simple,

I sent you login information via private email on 2 April. Did you receive it? I just sent again.

Thanks for your offer to help resolve this.

#13

Hi @ls4680 ,

Both elastic and lucene plugin were desactived :).
Enable lucene then reindex => that works. (tested on CRS big - 10)