Cannot access workspace with id/alias settings by Admin

For some reason suddenly the admin is not able to access settings page at all and I am getting the following error:

'Cannot access workspace with id/alias settings ’

this is weird, did you modify something? otherwise could try to clear the cache ~/.config/pydio/cells/static/data/cache and then you can rm -f plugins_*,
if this doesn’t work we will see how you can restore your acces through the database.

Nope nothing, for a few days was working normally and suddenly yesterday didn’t allow me to access Home, I went to workspaces and selected read/write again for Home for admin user. After sometime I wasn’t able to access settings at all.

Unfortunately I already tried this without any lack. I am using docker for cells and I am trying to find where in database I can change this.

It’s actually kinda hard to modify the database so, i will look onto the api and will tell you how you can modify this.

Thanks Zayn it will be nice if you can share the solution. We are one step before production release with your clients and this is a blocker right now.

Btw I observed something else I have a group created with users who have the administrator role and sometimes they lose the access to home and pydio always redirect them to settings. (this is a different case)

I think the easiet way is to add in idm_workspace_policies all the access for write/read/owner/role of admin for workspace settings.

I tried ^… it doesn’t work

Also for admin the Home button icon is not shown up completely.

Really weird the funny part is that the access list is correct.

For the record what I did to solve it is the following:

  1. I use cells-clt cli to create another user with admin profile
  2. I edited the normal admin user to have access in settings and home

after this everything worked.

could you list me all the issues that you encountered and what you did before they happened

For couple of days we were creating only workspaces and cells. After the weekend admin wasn’t able to access home. I had a different admin account and I edited the default admin account to acccess home and settings even if the checkboxes were selected.

After this I wasn’t able to see home icon button but I was able to see Settings button. Though the settings button was returning the error which I sent here.

I found that this is happening when I am updating the read/write permissions of workspaces in an admin user for some reason removes the home/settings read/write permissions for all admin.

Some of the admin users are in a separate group