Missing Cells from home page


#1

I created all my Cells as the admin user and granted access to individual users. About 40 different cells. Then 1 day half of them are gone from the admin users home page. I have to login with another user to access these cells, and that user doesn’t have access to edit permissions.


#2

Hi,
sorry for the late answer,
so your admin user lost access to cells, are they created by the admin user or another user ?


#3

Sorry I’ve been out since last Wednesday. But yes the Admin user created the cells, and now no longer has permission, and can not see the cells at all. Another user was granted access and can see the cells, but can not give permission back to admin.


#4

Hi @imedrisit we’ll try to reproduce this and keep you posted


#5

Just to try to see a pattern:

  • Did you know if your users had logged in and accessed the “missing” cells in between?
  • Would you happen to see a fixed number of cells in the list of admin?
  • Did you tweak the “Visibility” Tab when creating the Cells as admin?

#6
  • I’m not 100%, but I’m pretty sure they did access the cells.
  • I currently see 17 Cells, but should have 49.
  • I did not tweak the visibility tab. Not sure it was there before, this happened in version 1.0.1. I’ve since upgraded to current hoping that it would be patched.

Another user i gave access to can see all 49 cells, but that user doesn’t have permission to edit. I’m guessing the only way to fix this is in the MySQL DB, but I haven’t been able to figure out the tables.


#7

Mmm, this can be at two levels: ACLs and Policies. Do you think you could PM me a temp access to your server or is it too sensitive data? I could try to have a look using some api calls.
Never seen this case before, but I don’t like it…


#8

I may have found a solution. I moved myself into the group that can see the cells. This was not possible on the 1.0.* version. Now I can see that the Root Group does not have visibility. I’m going to edit the visibility, then move myself back to the root group. The other groups don’t have permission to edit visibility, so still not sure how it happened.


#9

what kind of access would you need? It’s on a linux system with a public visible website. I think i have ssh access locked down pretty tight.


#10

So you did find the cause (moved your user) and a solution?


#11

Just as a side note, maybe you should have created “workspaces” instead of “cells” in your case, if you wanted some admin-created spaces. Or you did want to delegate the administration of these cells to some other users?


#12

I’m sure this wasn’t the cause. But it may be a solution. I haven’t finished yet. The users are clients, not internal employees. So i wanted to be the owner of the cells, and just grant access to the client so that we can share data. But i needed to have access to all of it. Not sure if the workspace could be used the same way or not. But when i create a cell, it lets me create a user at the same time, so that was pretty convenient. I create a cell and user by the same name as my clients and it keeps it organized.


#13

And… that didn’t work. When editing the Visibility, the box marked “You” was already checked. Even though i clearly did not have visibility before moving myself to that group. So i added the Root Group to the visibility, then moved my admin user back to the root group, and still no luck. Also I find it strange that the groups are folders, in order to have the permission the user must be in the folder. It’s just a little different that how most permissions work. So i created another user at the top (root) level that is just a standard user. Root Group is listed as a role. And that account can’t see any cells that i granted visibility to “Root group”. :frowning:


#14

So now i’m explicitly granting access to the Admin user. It seems like its working. I turned my new account into an administrator just to give access back to the real administrator…


#15

I’m still not sure of what happened here, can you re-explain the exact scenario from the start? I would like to reproduce this.


#16

Sure. This all happened using the 1.0.1 version, and since i’ve upgraded to the current version hoping it would fix itself.

  • I created about 50 cells under the Admin account.
  • As I created the cell, i also create the shared user account for the client and give them modify access to the cell.
  • I also have a group call “Client Access” that i grant access to the cell at the time of creation.
  • Then a few weeks later, I no longer have visibility to 30 of these cells.

I use one of the accounts in the Client Access group to verify that the individual users do not have the ability to edit the visibility or the access. This account also still has access to all the cells.
Granting visibility rights to the admin account doesn’t fix it, but explicitly sharing the cells with the admin account does. I had to create a new admin user in the “Client Access” group with the “Root Group” role in order to edit the permissions.

Also let me know if giving you an account will help you investigate. We can easily set you up with an account on the web site.


#17

Ok this is weird, and happening right now to my new administrator account “Adam” i am using to give access back to the admin user. I edit a cell and share with the admin user, and when i hit Save, I loose access to another cell. I have a screen shot that shows the list of cells on the left, and the one on the very bottom disappears when i hit save

But now i’ve noticed that there seems to be a limit of 50 Cells that i’m able to view. I think I have 55 or so total, but i saw them stop showing up as i granted access, and it seems both accounts have a total of 50 and stop getting more. That may be a clue as to what happened. Maybe when i created cell 51 it cause some sort of stack overflow and screwed things up.


#18

Here is another odd one… Admin user shows up twice with different permissions. And the “You” says i don’t have visibility even though i’m currently editing it. I bet this one disappears on me.


#19

Have you been able to reproduce this 50 cell limit?


#20

Hi, please be patient, we’ll have a look at that - very probably a bug here. You would have to wait for next version (not the one announced today)