Can´t delete files

#1

I´m running Pydio Cells Home Edition 1.4.1
After a reboot, nobody can delete files anymore.
In the file system, the files are deleted and moved to the recycle_bin but in cells i still see the files in my folder and not in the recycle_bin.
In the logs i find:
Ts : 1553087559
Level : error
Logger : pydio.grpc.tasks
Msg : cannot run action actions.tree.copymove: The specified key does not exist.
SpanUuid : d5817147-4b11-11e9-b97f-001f294ddac8
SpanParentUuid : d5094533-4b11-11e9-a01b-001f294ddac8
SpanRootUuid : d5094533-4b11-11e9-a01b-001f294ddac8
OperationUuid : copy-move-22525792-ff05-4929-a0e0-b6dc76fbde55-0a41b322
HasRoot : true

I´ve tried to re-synchronize the storage, but witch no success.

Can anyone help me?

#2

Hi,
so basically you were adding files through the file system,
and then i guess you resynchronized them?

Could you try to resynchronize and also run the reindexation job,
you can find the job in the scheduler.

#3

Hi,

uploaded the files with the browser.
I ran both jobs, i still can´t delete files

#4

Hi,
when you say after a reboot was there a user upload/deleting doing any kind of operation during that?

#5

i really can´t say
Before the reboot only one user could not delete files. Now nobody can delete files
I get errors when i try to resync the storage:
Ts : 1553157471
Level : error
Logger : pydio.grpc.data.sync.abteilungen
Msg : Error while deleting node - {“id”:“go.micro.client”,“code”:408,“detail”:“context canceled”,“status”:“Request Timeout”}
SpanUuid : span-4

#6

i even can´t create folders now. it looks like a database issue

#7

I have the same issue, normally, what kind of logs should we give you to track down that nasty bug?

Thanks,
Yannick

#8

Hi
Ok let’s digg that.
If a re-sync of the datasource does not solve the issue, this is indeed a nasty bug. Do you see any errors in the logs while resync’ing ?
-c

#9

Hey Charles, could you tell me what log I should look at? Like the one on the web UI or in the filesystem in ~/.config/pydio/cells/logs? I used to be able to just restart the cell service and everything would start working again. But now, it happens very often and restarting does not solve the issue.

But please let me know what you need exactly to trouble shoot the issue, I’ll give you everything you need :stuck_out_tongue:.

Thanks,

Yannick

#10

Hi Yannick
Probably the simplest way is to restart cells manuallly not in production mode (–log=info), and check if you see errors here, and if not switch to debug (but that pretty awful and generates too many logs, we have to work on that).
Maybe you should first describe the structure of your data : what kind of DS (fs / s3), if FS is a mount of something, how many files (roughly), big files , etc… Even better could be that you find a reproducible scenario… and eventually send us a list of all your files/folders that we can recreate locally with “fake” files but same dir structure.
We are working on these indexation issues right now, so hopefully I can point you to a test binary to see if it’s getting better at the beginning of next week.

#11

Alright Charles, We have a dedicated server hosted in a vmware architecture running:

Distributor ID: Ubuntu
Description: Ubuntu 18.04.2 LTS
Release: 18.04
Codename: bionic

The OS is running off of a single virtual hard disk and the data is on another virtual hard disk and mounted under /datastore and all rights are assigned to the Pydio user.

the datastore looks like this:

/datastore$ tree -L 2
.
├── lost+found [error opening dir]
└── pydio-data
├── cellsdata
├── drops
└── personal

Then we have 3 Datastores:

  • cellsdata
  • drops
  • personal

Which uses the local Peer address: 192.168.10.X (As I understand, this is for local communication only right?) and the folder is linked to the /datastore/pydio-data/datasource-name

Then I get the following error when trying to delete a file:

ERROR pydio.grpc.data.sync.personal Error while deleting node {“path”: “/ling.accent/11422 - TLZ - PSA Taltz Chinese PatientBrochure_Simplified_v3[1].pdf”, “error”: “{“id”:“go.micro.client”,“code”:408,“detail”:“context canceled”,“status”:“Request Timeout”}”}

And I’d get the following error while trying to create a folder(But there are a lot of them):

ERROR pydio.grpc.data.sync.cellsdata Error while creating file {“path”: “test/.pydio”, “error”: “{“id”:“go.micro.client”,“code”:408,“detail”:“context canceled”,“status”:“Request Timeout”}”}

ERROR Could not find DataSource pydiods1 {“currentSources”: [“drops”, “personal”, “cellsdata”]}
PS: I disabled pydiods1 and change Pydio.json default datastore from pydiods1 to personal and this error is gone.

Strangely enough, its alway related to a Request timeout, could it be related to micro services (I don’t know Go to be honest, but I’m a software architect ;)) and I can upload files, but everything else seems to be queuing request which times out.

I just disabled datasource pydiods1 to validate it wasn’t causing the issue and since we’re not using it.

I could provide you with the entire log from today if you care to tell to which email address I could send it to.

Let me know what to do next.

Thanks,

Yannick

#12

mmm, i’m not sure it’s that simple - you’d have to create the associated thumbs, versions, binaries folders as siblings of the personal folder.
Maybe this is the root cause of issue …

#13

The issue was and still occurs with or without the Pydiods1 datastore being present or not. Please tell me what to do to get pass this issue as its pretty much unusable at the moment.