Ajxp_access.log not rotating proper-breaks services

We recently upgraded from 8.0 to 8.2.1, it went swimmingly

Issue we ran into after is ajxp_access.log is not rotating proper at 23:59
and from what I see it breaks services. In addition public links stop working.

only way to resolve temporarily is to re-create log file with symlink
and restart services.

what php version are you using?

Hi zayn,
currently 8.2.1 is pydio version
using remi-php5.6

in short i was able to resolve issue with recreating symlink with proper permissions
just curious as to why an upgrade just changes permissions.

what the upgrade does first is check if it can read/write the pydio files (not what you have stored in workspaces etc…) and then the upgrade will start to modify,add what’s need to match the updated version.

by the way, if you could upgrade php to the version 7 it would be great as it’s faster and has new stuff. ( and also there some changes for example the mcrypt package is deprecated on php 7 therefore you need openssl)

I see.

So why you are on here, here is another question in regard to the “Application Logger” settings.

Log Folder= /var/log/pydio/
File Name Pattern=log_date(‘m-d-y’).txt
Files Permissions= 770

what i find interesting on a brand new build of 8.2.1, without importing database from a previous server (migration-path)

The logs simply do not show up ( like I have no idea where they are at or going) Plugins are installed, enabled
as I see it.
My guess is I need to create ajxp_access.log file with proper apache permissions and symlink

ya know, i did try to upgrade to various php7.x versions
and I always got some php56 (remi version(s)) dependancy issues with
three packages, do not remember them all off hand, one was php7 version of mcrypt, it wanted version from remi 5.6

I gave up on that en-devour

yeah if you have other stuff depending on your php 5.6 packages it could be trouble unfortunate.

It could be that your pydio doesn’t have the right to write in the /var/log folder, what you could do to make sure would be to create a folder on your /home/user/log(to test), give it the rights (770 for instance ) and change user to www-data.

ya, as i suspected
just created the files with symlink with proper apache permissions and all is good
after a httpd24-httpd restart.

Thanks for your help zayn