4.0.0-alpha, backward compatibility and version choice

Dears,

When a brand new release appears, the same question arises.

  • Will it be fully backward-compatible with current version (no lost of data, configuration, …)?
  • Is it better to start fresh with such an alpha or to start with the stable in the hope that a smooth upgrade to the next release will be possible?

What do you suggest for a new (long-term) installation?

Hey :slight_smile:
1 - we always keep backward compat as much as possible. If a major version breaks something, it would be worst case an API, but never a configuration or data.
2 - alpha means alpha : never to be used in production !!