Unable to login after fresh run under docker-compose

Hello, the same issue is for me too (after containr up\down). Using Docker-compose with below configuration I run the container. I was able to open installer using url …:8080. On the DB configuration page Ihave entered host (mysqldbase) and pydio username\pwd (adminuser\adminpassword). After installation in the login form the Login failed is displayed once credentionals were entered. In the log the following error is displayed:
cells_1 | 2021-09-08T18:51:12.740Z INFO Login failed with {“id”:"",“code”:0,“detail”:“invalid_request”,“status”:""}

If incorrect password entered in the form on log the following different record appear:
cells_1 | 2021-09-08T18:54:06.760Z INFO Login failed with {“id”:"",“code”:0,“detail”:“password does not match”,“status”:""}

I have added mydocker-comfig.yml in attachment . The proxy-network is a bridge network with
docker-compose version 1.29.1, build c34c88b2

Please reply which information is required to solve the issue. From Cells container I able to ping mysql server using their hostname mysqldbase:
/var/cells # ping mysqldbase
PING mysqldbase ( 56 data bytes
64 bytes from seq=0 ttl=64 time=0.137 ms

In the mysqldbase container it’s possible to open cells database using mysql cli and then open table idm_user_idx_tree - record with admin user exists, that means that during setup connection between cells and mysql works. Instead ofhostname mysqldbase I tried to enter IP address - result is the same.

I set CELLS_LOGS_LEVEL=debug and the followin log ( added in attachment ) is displayed after docker-compse up and when I enter credentionals.

uname -a
Linux hostname 5.4.0-81-generic [#91]-Ubuntu SMP Thu Jul 15 19:09:17 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

/var/cells # cells version
Pydio Cells Home Edition
Version: 2.2.9
Built: 01 Jul 21 16:47 +0000
Git commit: [cf8dab5]
OS/Arch: linux/amd64
Go version: go1.15.13


Could you try the following to further dig and diagnose (I advise to get out the debug log level - it is not necessary at this point):

  • What happens if you restart the “cells” image only with smth like: docker-compose restart cells .
    • Do you see any error when the process starts?
    • Can you login ?
  • Can you try a similar deployment with the latest dev version ( pydio/cells:unstable ): we have added a more robust service starter for such setups and we know wait and retry if the DB is not ready

Also, at this point:

  • the explicitly defined network is not necessary
  • you should double check upon re-install that you have correctly cleaned the host FS: as you are mounting local folders for both mysql and cells, these folders should be empty before first start. (You might have some trash from a previous try)

By the way, in your compose file, the CELLS_EXTERNAL env var is not correct and should rather be: https://shared.home

Bruno, thanks for your help. I have changed only CELLS_EXTERNAL (‘https://’ added in .yml) and after that login was successful using :latest version.

Also I disabled debug log level, then run “docker-compose restart cells” and after restart login was successful too. In log file there are no errors, just [Note] for mysql: when restart is started “Aborted connection” is displayed. Log is here:

Also login was successful when I set CELLS_NO_TLS=1 and CELLS_EXTERNAL=http://shared.home.

For pydio/cells: unstable :

  • I have removed explicity defined network and clear local folders for both mysql and cells. .yml is on githubissue page due to here are two link limitation.
  • Installation server was started and setup was successfully opened.
  • After all was filled the “Server is starting” is displayed. Much userfrendly than in :latest version.

In my case when the login form appears Login was failed for first attempt, then I have entered wrong password to see which message will be in log in that case. The message was the same as in first case with correct password.
After sametime in log " INFO pydio.grpc.oauth started" and “INFO pydio.web.oauth started” are displayed and only after that messsages login was successfull. May be Login form should be displayed only when pydio.grpc.oauth is started, not earlier. Maybe there was a some delay on my hardware (I tried two times, behaviour was the same - Login form is opened prior pydio.grpc\web.oauth were started). StartLog for :unstable is here:


I suspect that what have solved your issue is the Cells restart you have done after changing the External URL. As I said, there are some start known issues on the 2.2.x branch on docker when you restart an already installed cells with a not-yet-ready connection (that are addressed in the next release :slight_smile: )

But anyway, thanks for marking this as solved and happy file sharing!

This topic was automatically closed 11 days after the last reply. New replies are no longer allowed.