Login Failed With Invalid Request After Clean Installation

I believe I have a similar issue to the one mentioned here. Login Failed with invalid_request after clean installation
My Docker compose setup like this

version: '3.7'
      image: nginx:latest
      restart: always
        - "80:80"
        - "443:443"
      container_name: production_nginx
        - ./nginx.conf:/etc/nginx/nginx.conf
        - ./certs:/etc/wwwcerts/
        - ./letsencrypt.conf:/etc/nginx/snippets/letsencrypt-acme-challenge.conf
        - ./letsencrypt/:/etc/letsencrypt/
    # Cells image with two named volumes for the static and for the data
        image: pydio/cells:latest
        restart: always
        hostname: cells
          - G:\\piyio\\cells\\:/var/cells:rw
          - G:\\piyio\\extrafiles:/extrafiles

          - "HAMJONES-PC:"
            - "VIRTUAL_HOST=subdomain.yourdomain.tld"
            - "LETSENCRYPT_HOST=notafraid.app"
            - CELLS_BIND=cells:8080
            - CELLS_EXTERNAL=web.notafraid.ngrok.io
            - CELLS_LOG_LEVEL=production

    # MySQL image with a default database cells and a dedicated user pydio
      image: mariadb:10.3
      ports: ["3306:3306"]
      restart: always
        MYSQL_ROOT_PASSWORD: 1nLUOGtfhojfyzZPfrsc
        MYSQL_DATABASE: cells
        MYSQL_USER: pydio
        MYSQL_PASSWORD: CxWe86c52htaHWaJjCaH
      command: [mysqld, --character-set-server=utf8mb4, --collation-server=utf8mb4_unicode_ci]

      image: namshi/smtp:latest
      restart: always
        - "587:587"
        - "KEY_PATH=/etc/certs/domain-key.pem"
        - "MAILNAME=notafraid.app"
        - "CERTIFICATE_PATH=/etc/certs/domain-crt.pem"
        - "SMARTHOST_ADDRESS=smtp"
        - "SMARTHOST_PORT=587"
        - "SMARTHOST_USER=myuser"
        - "SMARTHOST_PASSWORD=secret"
        - "SMARTHOST_ALIASES=smtp"
        - ./certs:/etc/certs/

    data: {}

And all of my logs up until I have that error.

This is after a clean install with no files saved on my computer.
I have tried almost everything. The only thing that works is using a different version (older)

I’m having the exact same issue here, clean install with docker-compose, only difference to the demo-file is, that I added “CELLS_NO_TLS=1” as environment variable, otherwise 100% the same as here

I also tried to just docker-compose down and up again, as described in the other post reporting this Issue (OP linked that one), but that didn’t work for me. The Installer worked without problems though.
I think this is an issue with the official Docker image, maybe in combination with compose - it seems to simply not work out of the box but it’s also very hard to debug without having deep pydio knowledge, since the error doesn’t provide useful information.

Can someone please help here?

Posted on GitHub now: Admin login in docker image not possible · Issue #323 · pydio/cells · GitHub

Hello @mrsylerpowers ,

could you share your nginx configuration (make sure to hide sensitive info).

Also could you try to run your setup without a reverse proxy and see if the login request still fails?

Hello @zayn,
Here is my nginx configuration

events {
  worker_connections  4096;  ## Default: 1024

http {
server {
        server_name web.notafraid.ngrok.io
        listen 80;
        listen [::]:80;
        listen 443 default_server ssl;
        resolver ipv6=off;
        ssl_protocols TLSv1.2 TLSv1.3;

        include /etc/nginx/snippets/letsencrypt-acme-challenge.conf;

        location / {

                proxy_buffering off;
                client_max_body_size 100G;
                proxy_pass https://cells:8080$request_uri;
                #proxy_pass_request_headers on;
                #proxy_set_header Host $host;
                proxy_set_header Content-Security-Policy upgrade-insecure-requests;
                proxy_set_header X-Real-IP $remote_addr;
                # Redirect non-https traffic to https
                if ($scheme != "https") {
                    return 301 https://$host$request_uri;
                } # managed by Certbot
        location /ws {
        proxy_buffering off;
        proxy_pass https://cells:8080;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_read_timeout 86400;
ssl_prefer_server_ciphers on;

ssl_certificate /etc/wwwcerts/domain-crt.pem; # managed by Certbot
ssl_certificate_key /etc/wwwcerts/domain-key.pem; # managed by Certbot


Hello @zayn Even after removing my remote proxy I am still running into the same problem. With the exact same error. No NGIX

So… I guess it’s building the docker image from scratch then as the provided one is not working and seems to be not maintained/tested

Feel free. As a starting point, the code is in the github repo under tools/docker/images/cells. We would be glad to hear about your comments / feedback / ideas.

Let’s agree to disagree on this one, we try our best (as in FOSS) to maintain it and massively use the image in internal testing environments. To be sure, I just spinned of a new docker-compose environment on a web facing VM and could launch the env, run the install and login without issue, after accepting the self-signed certificate for https://example.com:8080

Thus said, a few ideas to further diagnose your issue:

  • are you behind a reverse proxy (this thread was about nginx at some point) ?
  • do you have any log in Cells when you unsuccessfully try to login with the admin user after install ?
  • have you tried to run docker-compose exec cells cells configure sites (the 2 “cells” are necessary, one for the name of the image in docker compose, one to call the binary inside it) to check if the Cells’ internal webserver is correctly configured ?
  • what happens if you do docker-compose restart cells while checking the logs ?

This topic was automatically closed 35 days after the last reply. New replies are no longer allowed.