Trying to create a datasource but fails

I have an Ubuntu server running v18.

I’m using AutoFS to mount a Drobo device to /mnt/drobo

The account running Pydio Cells does have write access to /mnt/drobo. The account can touch new files and delete them.

In Cells I see that I need to create a datasource. When I attempt to create a datasource pointing at /mnt/drobo I receive an error in the log saying the user account running the Cells needs to have write access to the parent folder.

How should mount the Drobo on the server so that Pydio Cells can access the files hosted there?


as you said, the log told you that you must have write access on the parent folder, that is here /mnt.

FYI, when you create a data source that points to /apath/parent/datasource-folder
the applicaton creates a hidden folder .pydio at /apath/parent/.pydio that is why the account running pydio should have write access on the parent folder.

In your case, I suggest you add a level, typically: /mnt/drobo/localds1 and put your files in localds1.

I was unaware that it needed to create a /apath/parent/.pydio folder. Now it makes sense why it needs write access to the parent.

Given this is expected behavior, do you know of any options to change where Pydio creates this .pydio folder?

Nope. you cannot change this behaviour and configure the relative path of the .pydio folder.