[Solved] Uploading NEF raw photos fail

upload

#1

When trying to upload a NEF file i get an error with no information about why it failed. I’ve tried several NEF files but all fail. This one is 19.06 MB, no where near the 2GB upload size limit.
Image of Error

Diagnostic

Client : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
Crypto Extension Detected : OpenSSL
Command Line Available : Yes
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 2048M
Memory Limit : 128M
Max execution time : 30
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : Linux
Session Save Path : /config/sess
Session Save Path Writeable : Yes
PHP Version : 7.1.17
Locale : C.UTF-8
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : Yes
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 2147483648
PHP Post Max Size : 1635778560
Users enabled : Yes
Guest enabled : No
Writeable Folders : [cache:true,
data:true]
Zlib Enabled : Yes


#2

Hi,
you could put your Pydio in debug mode and see what’s going on to so follow this :

DEBUG MODE PYDIO

Go to conf/bootstrap_context.php .
Switch this line to true : 
define("AJXP_SERVER_DEBUG" , true);

then you will have a stack on your webrowser’s console


#3

Sorry i just checked back. I did as you asked this is what i got. I tested a non-NEF file that was around the same size and got the same error, seems like something is off with the max upload size in the settings?
POST https://files.ammo-crate.com/index.php?secure_token=0zMPlEvbgQbfFwEFz2aTB1prbLvS0xF5&&get_action=upload&xhr_uploader=true&dir=%2FSite%2FProduct%20Images%2FRaw&auto_rename=true 413 (Request Entity Too Large)


#4

Hi,
yes it could be the php upload size values, try to modify them and see if the error reappears, to you can find them in /etc/php/<version>/apache2/php.ini files.
To make sure that the modifications were saved you can use something like php -i | grep upload_max_filesize


#5
root@3e59a5ae2ace:/$ php -i | grep upload_max_filesize
upload_max_filesize => 2048M => 2048M

Also checked the file itself and it says the same
I bumped it down to 1024M, restarted and ensured that the above said 1024M and i’m still getting the same error.


#6

Hi,
and what is your post_max_size i forgot to ask you about this value.


#7

1560M and apparently i need 20 characters to post anything on this forum…


#8

Hi,
could you also modify the upload_max_filesize & post_max_size in /etc/php/<version>/cli/php.ini then try once more.
As for the 20 characters i don’t have a hand on that sorry.


#9

That file also had the same values. i changed everything to be 1024M but no change in behavior.


#10
Client : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36
Crypto Extension Detected : OpenSSL
Command Line Available : Yes
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 1024M
Memory Limit : 128M
Max execution time : 30
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : Linux
Session Save Path : /config/sess
Session Save Path Writeable : Yes
PHP Version : 7.1.17
Locale : C.UTF-8
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : Yes
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 1073741824
PHP Post Max Size : 1073741824
Users enabled : Yes
Guest enabled : No
Writeable Folders : [<b>cache</b>:true,<br> <b>data</b>:true]
Zlib Enabled : Yes

#11

Hi,
your issue is weird, i downloaded a nef file here i hope that it was the correct formats and tested an upload i didn’t have any error occur, what happens with other files from different sizes, if you could test and tell me that it would be great.

This is my configuration and it worked perfectly,

Client : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3449.0 Safari/537.36
Crypto Extension Detected : OpenSSL
Command Line Available : Yes
DOM Enabled : Yes
Exif Enabled : Yes
GD Enabled : Yes
Upload Max Size : 800M
Memory Limit : 128M
Max execution time : 30
Safe Mode : 0
Safe Mode GID : 0
Xml parser enabled : 1
Server OS : Linux
Session Save Path : /var/lib/php/sessions
Session Save Path Writeable : Yes
PHP Version : 7.1.17-0ubuntu0.17.10.1
Locale : C
Directory Separator : /
PHP Opcode Cache extension loaded : Yes
PHP INTL extension loaded : Yes
PHP Output Buffer disabled : Yes
PHP File Uploads enabled : Yes
Magic quotes disabled : Yes
Upload Tmp Dir Writeable : Yes
PHP Upload Max Size : 838860800
PHP Post Max Size : 734003200
Users enabled : Yes
Guest enabled : No
Writeable Folders : [<b>cache</b>:true,<br> <b>data</b>:true]
Zlib Enabled : Yes


#12

Yea the NEF doesn’t really matter here, i realized after i started this thread that it’s any file that is of similar size or bigger. Also checked nginx and it’s set to not check the body size.


#13

Thank you for your help, i fixed the issue. I’m using an nginx reverse proxy to point to my pydio server. THAT server was killing the upload because of file size as it was set to 8MB >.> . All good now.


#14

Hi,

yes i just wanted to be sure since you were only talking about it, i wanted you to test other formats etc …

i’m glad that you found the error.


#15