Unable to upload files larger than 60 ko

upgrade Pydio 7.0.4 to 8.2.5
Debian 8
PHP 5.6.40-0+deb8u11

Hello everyone,
I am facing a problem that I have not been able to solve for several days:
My users complain that they can no longer upload files.

I noticed that all files larger than 60 KB get in error.
It seems that the problem appeared after the change from pydio 7.0.4 to 8.2.5 but I am not sure.

in /etc/php5/apache2/php.ini
memory_limit = 128000000
post_max_size = 600000000
upload_max_filesize = 512000000

Can you help me please?

Below the error in the log /var/log/apache2/error-XXXX.log

[Sun Apr 26 17:20:11.831732 2020] [:error] [pid 1838] [client xxx.xxx.xxx.xxx:62255] PHP Fatal error: Uncaught exception ‘Pydio\Core\Exception\ResponseEmissionExcepti
on’ with message ‘Could not send response!’ in /var/www/pydio/core/src/pydio/Core/Http/Server.php:259\nStack trace:\n#0 [internal function]: Pydio\Core\Http\Server->
catchError(8, ‘ob_end_flush():…’, ‘/var/www/pydio/…’, 158, Array)\n#1 /var/www/pydio/core/src/pydio/Core/Controller/ShutdownScheduler.php(158): ob_end_flush()\n#2 [
internal function]: Pydio\Core\Controller\ShutdownScheduler->callRegisteredShutdown()\n#3 {main}\n thrown in /var/www/pydio/core/src/pydio/Core/Http/Server.php on l
ine 259, referer: https://XXXXXXXX.XX/share

They are the params that should be changed. (use 256M format for better :slight_smile: ). post_max_size and upload_max_filesize should have the same value

  • Make sure that you are modified in the right php.ini. You can create a phpinfo() file in the root of pydio then brow it. You can see the correct absoluted path of php.ini
  • After changing php.ini, please restart apache
  • Set to empty Pydio >> Setting >> Upload >> Upload filesize then click “Save”

Hello c12simple

Thank you for your prompt answer.
You where right in checkin the correct path for the ini.php witch was /etc/php5/cli/php.ini => /etc/php5/apache2/php.ini and /etc/php5/cli/php.ini are exactly the same.
I corrected the values:
memory_limit = 128M
post_max_size = 512M
upload_max_filesize = 512M

I tried 0 or empty for Pydio >> Setting >> Upload >> Upload filesize

But still on error.

I was wondering why tiny files can be uploaded. Curious

It seems that PHP can’t handle the error.
May be an upgrade from actual PHP 5.6.40 to 7.2 can bring more informations about the error?
Is there a procedure to upgrade ? (may be remove previous PHP or something else?)

It seems that the problem comes from the version of the SMB protocol.
on Pydio 7.0.4 it was possible to specify the version of the SMB protocol to be used by smbclient in the configuration of the Samba driver.
The problem on the last version of Pydio 8 (8.2.5) the field where it was possible to enter arguments to the smbclient disappeared.

I tried to configure smb.conf (by adding max protocol=SMB2) but there is no effect. It seems Pydio really needs the entiere command line in it’s config.

So question is how can we add SMB2 argument in Pydio 8.2.5 ?

Please read carefully the instruction of samba config in Pydio (the last posted screenshot)

Yes I read it and it’s all Ok on this side about smclient. What am’I missing?