[SOLVED] Samba Workspace

Pydio 8, ldap, ubuntu 18 LTS, smb, samba


I have enabled ldap and logins are working fine. Referring to guide above I configured a new samba share workspace. When a user tries to access the workspace it asks for credentials and does nothing.

What am I missing? Is it an SMB 3.0 thing?

If you are going to configure samba workspace with ldap user, please make sure that:

  • Store credential in session should be YES (in configuration of authentication)
  • In config of samba workspace, you must not specify credential but check “Use credential in session”. Other params should be default value.

I did not have store credentials enabled, and that is now enabled.

Unfortunately still stating “Workspace is empty”

As a note I have set this up before on Pydio 7, but this is a fresh Pydio 8 and new SMB server.

Another question: Did you install smbclient? Or does smbclient path is configured in PYDIO/conf/conf.access.smb.inc (or /etc/pydio/conf.access.smb.inc)?

I enabled SMB Authentication in the “Available Plugins”, and enabled Samba in the workspace plugins.

I can see those folders you do mention, so unsure if they are enabled or not.

Just try sudo apt install smbclient then which smbclient to make sure you have correct path.

<?php /* * Copyright 2007-2016 Abstrium * This file is part of Pydio. * * Pydio is free software: you can redistribute it and/or modify * it under the terms of the GNU Affero General Public License as published by * the Free Software Foundation, either version 3 of the License, or * (at your option) any later version. * * Pydio is distributed in the hope that it will be useful, * but WITHOUT ANY WARRANTY; without even the implied warranty of * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the * GNU Affero General Public License for more details. * * You should have received a copy of the GNU Affero General Public License * along with Pydio. If not, see . * * The latest code can be found at . */ defined('AJXP_EXEC') or die('Access not allowed'); // This is used to manually configure the absolute path to php binary on the local machine // Remember to clear the plugins cache after changing this value. $DRIVER_CONF = [ "SMBCLIENT" => "smbclient" ]; The above is the contents of the conf.access.smb.inc ---- looks mostly default.


Do you have “smbclient” in your server ?

Yes installed, as you described.

which client: “/usr/bin/smbclient”

Replace by:
[ “SMBCLIENT” => “/usr/bin/smbclient” ];

Then in configuration of workspace, user credentials:
Domain: domainName\ (if you have windows samba)
User: blank
Password: blank
Session credential: YES
Allow alternative login: No

Hmmm something is going on with the Windows Samba server that hosts the share. I created a new Share on a Windows 10 machine and it works fine there.

Thank you for all your help.

Would you happen to know if there are any limitations with Windows Server 2019? When setting up Samba share?

I’ve never tested with 2019.
So to make sure that it works on linux please try with following command.

smbclient //server_ip/share -U username
then enter password
Note: you must specify the domain in username such as: DOMAIN\\userid

If you get error, try again with debug
smbclient -d 5 //server_ip/share -U username

That helped me a lot. From the errors I was getting from those commands it was a DNS resolution issue.

All is working. Appreciate all your help.