Access Samba Share from Pydio on IIS10


I did a fresh Installation of Pydio 8.0.1 on Server 2016 with IIS 10 and PHP 7.1.
Afterwards I configured authentication via AD and mapped attribute “memberOf” to “GroupPath”.
This created my users and groups.

Now I enabled the Samba driver and tried to setup a workspace to access a samba share.
I tried so many things to get it to work but I didn’t find a solution. Also the docs didn’t help.

What is the easiest way to access my samba shares (also W2k16) on another server?


@c12simple can you help on this? thx

Even if I understand the interest of your choice.
I will make this choice:
1 - assign drives to your Windows shares on the IIS server
2 - then use the FS drivers (not the SAMBA drivers) for your REPO

FS drivers is more stable and more efficient
Just my point of view

PS : another advice. It is too early to use php 7.1 for many reasons. Make your test with PHP 7.0

Pydio + IIS does not work with Samba share.
Because access.smb plugin in Pydio relies on smbclient program and access.libsmb requires libsmbclient.
Both smbclient program and libsmbclient lib are now available only on *nix system. There is a version of smbclient for windows but does not stable.

Thx for the advice and infos

Okay, I’ll turn off samba.
Which way do you advice for accessing a Windows share?


Switch to linux system. You can use image of virtual machine (ovf) from :

Okay, just that I understand it correctly:

There is no other way of accessing windows share from IIS?
Basically u telling me there is no real support for pydio on Windows/IIS?

Not exactly: There is no way to access windows share with NTFS permission
If you mount windows share to the server, Pydio will access this mount as a local driver.

It’s not recommended but pydio supports Pydio + Windows + IIS with limits: samba share with ntfs permission, file size < 2g, caching service …

Hi @c12simple,

I mounted my share with drive letter Z: and created a workspace. Unfortunately nobody can see this workspace.
The server is connect to AD and there is a group call “Bilder-User”, so prefs are:

Label: Bilder
Standard Rights: read only
Alias: bilder-1
Group: /Bilder-User

Driver (File System)
Path: Z:/Bilder
Rights: 0644

Did I miss something?


The default permission of new workspace is none. After creation new workspace, you should grant permission for users in Pydio >> Users & Workspace >> Users or by roles (recommended), or by group

Hi @c12simple,

thanks for the info.
I removed the group under section GENERAL and added read right for the group “Bilder-User”.

Unfortunately I still can’t see the workspace.

Another problem: When I temporarily added the workspace to my testuser, he could see but not access it.
Error: Missing user in node URL

Anything else?

Because he does not have sufficient permission to access (NTFS permission).
It depends on how did you setup this workspace by using Session credential + Auth ldap or with a fixed smb account

Unfortunately this is not correct.
The testuser ist in the group “Bilder-User”. This group has read access (NTFS) to “Z:\Bilder” (but not to Z). I even temporarily added administrative rights to this user, but still the same problem.

Again, I don’t want to give rights to certain users, but to the whole group. Everything else should be done by AD. But nobody who is in this specific group can see the workspace.

Where do I add configure these? I couldn’t find these options!

It requires at least “List folder” permission on Z

When you install Pydio with IIS, the user access to Z:\Bilder is iis worker (in this case is IIS application pool). You should grant access to this user.

Note: It’s recommended not use LocalService, NetworkService, LocalSystem but you create a new application pool for Pydio.


Hi @c12simple,

has been a while. Didn’t have much time to go on.
I’ve tried this now but still the same error message:

I created a new domain service user called “pydio”.
This one has at least read access to everything we talked about.
It is also the AppPool User:

2017-12-18 15_32_09-Exchange 2016 - ex2016 - Remotedesktopverbindung

This user also has read access to the FS Share (Z:\Bilder):

(next post)

So any other suggestions?

FS Share Rights:

2017-12-18 15_35_40-bilder

How about the permission of “pydio” on Z:\ ?

They’re the same as with Z:\Bilder !
2017-12-18 17_57_11-bilder2

Hello @c12simple,

no more suggestions?
I’ve even downgraded to php 7.0 but the error still occurs.
“Mission user in node url”