[solved] Pydio 8.2.5 Background image is displayed after login. Pydio will not take me to

Hi Community,

I am new to Pydio and newer to MySQL, PHP etc, so I apologise upfront.

Quick Summary:
My admin user after logging in, is not sent to the welcome screen. Instead:

  • The background image is displayed and
  • there is no way to exit the web portal
  • login form displays after logging in,
  • there is no logout option.

Tech details:

  • Fresh install for about 2 weeks
  • Pydio 8.2.5
  • linux
  • apache
  • safari or edge

Issue when accessing web port using:

  • Admin user

Same results on MAC bigsur/safari, PC/edge, win10

In more detail:
Reproduce Steps:

  1. Load Pydio login
  2. Login screen loads
  3. Enter credentials
  4. Select ‘ok/login’

a. Taken to USER Home Screen of Pydio

FRONTEND_Actual Results:
b1. Login form disappears
b2. Background image is still displayed
b3. No error message displayed for incorrect password
b4. No error message displayed
b4. There is no way to navigate to users ‘home page’

With the user still “logged in”:
Also tried using a direct link:
b5. added ‘/welcome’ - no affect, no login form displayed, no error displayed
b6. paste location of known resources - no affect, no login form displayed, no error displayed

  • Have tried on a PC and it only happens on the admin user.

  • Only way to get back to login form/page is clear cache and browser history.

Checking the logs

[1] login for non-admin-user

SOURCE= SecureTokenMiddleware.php
message= I.70
params= message you are not allowed access this resource

  • But the user is logged in without any issues
  • Able to upload a file successfully

[2] Admin-user login
SEVERITY= warning
SOURCE= Pydio\core\services\authservice
message= Login failed
params= user=xxx;error=invalid password

  • No error is displayed on the frontend


  • The credentials work on the Pydio app
  • The app does not have any admin features so I cannot make any changes in the frontend using the iOS app

Any ideas? This user was the one created from outset to complete installation.

27.jun.21: update:

went into backend change the password so now no error in the logs.

but still no change, background is displayed

Have been able to resolve and just realised how simple of an issue it was.

Root cause, the user was being sent to a location on Pydio that they had not been granted access to (even as the admin!) quite strange. Anyway I resolved it if your interested by:

Going into the backend

  1. phpmyadmin
  2. create a new user
  3. add admin rights using
  • Setting repo_uuid to ‘ajxp.admin’
  • Setting rights to ‘1’

Remember to log out of the app if you have logged as that said user.

It may take a little time to propagate or update.
Hope this helps someone else who gets stuck with the same issue


1 Like

This topic was automatically closed 11 days after the last reply. New replies are no longer allowed.