[solved] How to setup nfs share to a NAS device

Has anybody in the community hooked up a local NAS using NFS to pydeo cells. When I attempt to create a new Storage item I have been getting minio errors and have not been able to establish a working mount.

here’s a link to the details.

I would just like to see the configuration of a working mount. especially the target directory configuration.

I am now familiar with both the binary and docker installation process and I have had the linked problem in both places.

Really could use some help.

1 Like


You should create new datasource in Cells from a sub folder of mounted folder.

Some microservice store its database in Cells_Data_path/services. Please make sure this folder is on a local disk. Otherwise, you’ll have an unstable setup.

1 Like

I got it to work. Thanks for explaining. I guess I needed to see it multiple times - I did find other posts that said the same thing but i finally got it.

1 Like

I’d love to see how you did your NFS configuration on the NAS, if you’d willing to share it — I’m a Synology NAS user as well, but whenever I try to do something similar, somehow, I run into lots of permission issues (either on the NAS or on the home-based Pydio Cells installation, running on a separate machine). Ultimately, I gave up on NFS and used SMB instead. However, even though SMB might be easier to set up (at least if you use the point-and-click interface…), it’s far less efficient than the superfast, almost-zero-overhead NFS, which, on top of that, is almost treated by any Unix-based OS as being a ‘native’ filesystem, i.e. you got the kernel supporting it straight out of the box, no need to add any special drivers or running daemons or even… well… configuration, I guess. Except, of course, for permissions. That’s where I always miss something crucial.

Granted, @c12simple’s explanation makes a lot of sense — if I’m not mistaken, Pydio Cells requires to write something on the root of the Cells-mounted filesystem to get it to work, thus the need to mount it on a subfolder. I wouldn’t have guessed it myself :slight_smile: (it’s not that obvious unless you know what you’re doing).

I suppose that this is just something for the Community Edition, since Cells Enterprise allegedly already comes with several filesystem ‘plugins’ (so to speak), thus making this kind of configuration pretty much automatic.

Still, even with Enterprise, you need to get the permissions right on the NFS server :stuck_out_tongue: … which seems to be my problem.

To cover all the bases:
On the Synology:

  • On the Synology server setup the shared folder / NFS permissions to include the server Pydio is running on.
  • On the NAS folder root I added a subfolder called base.

On the Pydio box

  • add a folder under /mnt called subfolder (for instance)
  • change the owner for both folders to the user that runs cells.
  • change the permissions on both folders to 777 you can trim these back after you get it working if you like.
  • In the Cells Console add a Storage / Datasource to use the folder /mnt/subfolder/base

Note that the first two folders are the mount point for the Synology on the linux box and the third subfolder is on the Synology.
Don’t forget that all these folders should be lowercase with no spaces.

1 Like

This topic was automatically closed 11 days after the last reply. New replies are no longer allowed.