[Solved] Cells public shares: ACCESS options does not work


#1

Hi community,
can somebody please help me with this problem?
Public shares work as long as I don’t set any access options like “Password”, “Will expire on” or “Allowed Downloads”.
Password: If the recipient clicks on a link with password, he can log in successfully and the login window disappears. But the shared file/folder is not displayed.
"Will expire on": When the recipient calls up the link in the browser, the message “Sorry, this link is expired”! appears immediately. But it hasn’t expired.
"Allowed Downloads": With this option set, the recipient can use the link, but the downloads are not really limited.

my installation: Ubuntu 18.04, Pydio Cells Home Edition 1.0.2 (stable)
Thank you in advance for your help
Meilk


#2

Hi @meilk
All these options should be functional, @zayn can you retest that?
Regarding the first one, what browser are you using when opening the link?


#3

Hi @charles / @zayn,
I have tested with all popular browsers (Firefox, Chrome, Edge, IE). But the result was always the same. I can enter the password and the input window disappears. After that, however, no download option appears. I only see the same background image as before login (but without login window).


#4

Hi,
i’ve tested the password if you only use that it works, you can also combine it with the allowed downloads(the limitation does not seem to work we will look into it) and at last the Will expire on which seems to not work and therefore displays an “expired link” (i’ve looked into my server s time zone etc…).
We will take a look into all of the above.

The password should be working take a look at my configuration.


#5

Could you please test something for the password,
Create a role and set the auto apply to shared
then go to the workspace tab and tick deny to all of the workspaces also do that on the application page to be sure.

After that recreate a public link and tell me what happens.


#6

Hi zyan,
only the password alone doesn’t work for me. I can’t see in your picture that you have set a password.
I only used the password option and the effect is as described above.
please look at my configuration:


#7

oops sorry i failed my screenshot, but i can log in and access the resource, could you try what i said above.


#8

here’s an updated screenshot of the configuration


#9

Hy zayn,
that was it. Your tip was to solve the mystery.
Thank you for your quick help.


#10

Hi,
we released a new update that fixes those issues, could you please upgrade and tell me if it’s working well.
If you see that you have a blank page don’t forget to check the external role permissions.


#11

Hi zayn,
good news. If it’s available tomorrow, I will do it then.


#12

It should be available on the stable channel, you can update your cells right now.


#13

Hi zayn,
Do I need to run .cells /install again?


#14

not at all, you can upgrade through the web interface, then you will just have to restart when prompted for it, by firstly closing cells with ctrl + c then using ./cells start and it should be good to go.


#15

Hi zayn,
I figured it out myself :slight_smile: I was updating over wget but after the restart I was just wondering that cells no longer listens to port 443.
But “sudo setcap ‘cap_net_bind_service=+ep’ cells” fixed everything.
So, now to the test: everything works fine now!
The functions “Allowed Downloads” and “Will expire on” work as desired.


#16

yes, this can work too as long as you don’t forget to set cap the new binary,
i’m glad that you have everything working well, if this is solved may i close the topic?


#17

Hi zayn,
I can confirm that everything works fine now (password, expired on, allowed downloads).
I still have a few things on the list. But I’ll ask them separately.
Thank you and all the developers for the quick help!


#18

no worries,
if you stumble upon issues you can post on the forum.


#19