[SOLVED] Can't share file or folder with my teams

Pydio 8.0.1
I’ve created somes groups, roles and users. I’ve granted the roles with the “Share with users of all groups” (partager avec des utilisateurs de tous les groupes in french).

On the user’s side I’ve created a team with users. When I what to share a folder or a file, I can choose users, groups and teams. Saving the Share with users works. Sharing with a team doesn’t work ==>

  1. I add the team,
  2. then click to the save button and with the refresh there’s no team selected.

In the info side, it says “Reinitialize the share”!

Is it a permission issue ? A setting is missing ? Or a feature request ? Beacuse sharing folders with teams woudl be awesome!

Hi squarou,
What DB are you using? This is not normal. Is it happening since you checked “Share with users of all groups”? If so it’s probably a bug

Hi Charles,

I’m using maria DB : 10.0.33-MariaDB and PHP 7.1

I’ve deactivated “Share with users of all groups” in the general settings and in the roles, but this didn’t solve. Is there something else I can check ?

mmm, it’s weird, it should work ok, teams are roles that can be assigned for shares.
Is your install an upgrade from previous version? Not sure that it could have an impact but just to make sure…

I’ve just upgraded from 8.0 but not really sure now.

I’ve tested to share with a whole group and that works. But still doesn’t do the job with teams. Maybe something’s wrong in my params. I’ll go deeper to check my configuration.

Is normal that the table ajxp_user_teams is empty ?
I don’t undertsand what does this table stands for ? As I have created for my user 3 teams. But I can’t find them in my DB.

yes, it’s not used anymore. Teams were previously stored in a separate table, but now they are simply stored as roles, you should see them in the ajxp_roles table.

Thank you Charles.

Here’s snippet for ajxp_roles : 1st is about a group which is OK for sharing with, an dsecond with my team. Let me know if you notice something wrong.

The group

	s: 12: "*groupPath";s: 1: "/";s: 9: "*roleId";s: 14: "AJXP_GRP_/test";s: 7: "*acls";a: 0: {
	}s: 13: "*parameters";a: 0: {
	}s: 10: "*actions";a: 0: {
	}s: 14: "*autoApplies";a: 0: {
	}s: 8: "*masks";a: 0: {
	}s: 14: "*lastUpdated";i: 1512402993;s: 10: "*ownerId";N;

The team now

        	s: 12: "*groupPath";N;s: 9: "*roleId";s: 15: "myteam-541";s: 7: "*acls";a: 2: {
        		s: 32: "91e8bba1ab420b6b9c539fec18d8c3e1";s: 1: "r";s: 32: "58c9c93a14adc4971c55713a9fbdbcdc";s: 1: "r";
        	}s: 13: "*parameters";a: 1: {
        		s: 19: "AJXP_REPO_SCOPE_ALL";a: 1: {
        			s: 9: "core.conf";a: 1: {
        				s: 17: "ROLE_DISPLAY_NAME";s: 12: "MyTEam";
        	}s: 10: "*actions";a: 0: {
        	}s: 14: "*autoApplies";a: 0: {
        	}s: 8: "*masks";a: 0: {
        	}s: 14: "*lastUpdated";i: 1512402904;s: 10: "*ownerId";s: 20: "xxxx@xxxx.fr";

Hi @charles I’m going deeper with that problem. I didn’t find that problem with a fresh install on the same infratructure.
But I noticed something.

I can select a user, a group or a team when I want to edit or create a shared folder or file. But saving only works for user and group, not for team.

I checked the console and the XHR response. For the POST share action, entries options remains empty array as you can see :

Whereas with a user or a group entries is note empty.

I tried this afternoon to reset the roles and user attributes but I didn’t find anything relevant.

Hi there !

I solved my problem by reinstalling Pydio and plugin to the database… Now I can share folders or files with TEAMS ! Thats a great feature !