Simple Lock failure case (bug)

#1

Ubuntu 18.10 based server running Pydio 8.2.2

  1. I created a Workspace Template that did not include Simple Lock

  2. I then created a Workspace (Test1) from the Template, and realized I wanted to try Simple Lock

  3. I added Simple Lock to the Template

  4. In the actual Workspace the option for “Lock” appeared in the menu

  5. When I click “Lock” it does nothing. There is no feedback about lock status and it does not appear as though the file is being locked in any way.

  6. I created a second Workspace (Test2)

  7. I uploaded a file to Test2 and attempted to lock the file, it worked as expected.

  8. I deleted Test2

  9. Test2 did not disappear from My Workspaces, but was innaccessible with error “Could not find workspace with id/alias…”

  10. Went back to Test1 and tried to lock a file

  11. It worked this time!

  12. Logged out and back in

  13. Test2 is now removed from My Workspaces

Summary: Adding Simple Lock to a workspace template did not activate it until after a new workspace was created from the template, this sounds like a plugin initialization problem. Deleting a Workspace did not immediately remove it from My Workspaces (and refreshing the browser did not work either), only a full logout/login cycle removed it. Seems like a caching issue.

#2

Hi,
indeed it seems to be a caching issue (maybe related to your previous issue about the right click menu) i’ve reproduce this one

  • created a template without simple_Lock
  • create a ws using this template
  • added simple lock to the template
  • now i have the menu appearing in the right click inside my previously created ws, when i lock there’s a new text appearing saying (locked by you) and you have the lock (logo) appearing too

Are you using some sort of caching, redis, memecache or else?

#3

I’m using a basic standard install of Ubuntu Server 18.10 w/ common LAMP packages, nothing special. Afaik memcache is not enabled.

I’m not sure you followed my steps exactly. Please try the following on a Pydio install that has never used Simple Lock before, this may be important to the issue since I think it’s an initialization issue more than anything.

  1. Create a new Pydio.
  2. Create a WST without Simple Lock
  3. Create a W and open it, create/upload a file or two. The point here is to use it so it is fully initialized and working.
  4. Add Simple Lock to the WST
  5. See if it works correctly in the W on files/folders already created there.