Few issues after upgrade (Bookmarks, error in log, workspace group restriction)

I upgraded from Pydio 7.0.3 to the latest Pydio 8.0.1. Upgrade went smooth and for the most part everything working great. However 3 things.

  1. User bookmarks has completely disappeared from the interface. I have went through every setting multiple times in the admin panel and am unable to figure out how to make user bookmarks appear. I have tried to “Toggle” the bookmarks off and back on without success (this option is still visible) I also ran Lucene index (well, have running, we have about a million files) and tried to enable the sharing plugin (I have always kept this disabled)

  2. Error in error log. There does not appear to be anything “broken” but this error appears constantly for all users. 2017/12/11 12:12:26 [error] 19539#19539: *8371 FastCGI sent in stderr: “PHP message: [PYDIO] IP x.x.x.x | user shared | Error | error l.70 | from SecureTokenMiddleware.php | message=You are not allowed to access this resource” while reading response header from upstream, client: x.x.x.x, server: x.x.com, request: “GET /upload/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php/php7.0-fpm.sock:”, host: “x.x.com”,

  3. If I set a workspace to be viewable by only a specific group (LDAP group), my users assigned to that group can not see the workspace. If I assign a group that was created in Pydio to the workspace, it’s viewable without any issue. Any suggestions?

Thanks everyone,
Rick Roll

Hi Rick

  1. Indeed, bookmarks list was removed for the moment - we still have to reimplement them
  2. do you have an open window or a sync client running somewhere?
  3. should be working fine, how do you actually map the ldap groups to pydio ?
  1. Got it, hope you get that implemented soon. Was a big feature for us with folders many layers deep.
  2. There is no window open anywhere, and it seems to be appearing for all users randomly. We do not use the sync clients, only web based Pydio
  3. I setup the LDAP query to pull the users from the group named Employees in AD. Then Pydio maps that group automatically: This is the group filter query (&(objectClass=group)(name=Employees))
    Works great, but if I assign a Workspace to be restricted to Employees group, the user who is apart of the Employees group will not be able able to access the workspace. I have other Pydio created groups for instance ‘Group1’ and if I set a Workspace to be restricted to that group only, it works just fine.

Thank you.

Ok, thanks for the motivation, I just pushed something for the bookmarks list :wink:
For the ldap groups stuff, let’s ask @c12simple

Please post your configuration of ldap plugin