Share with users: directory infinite loading


I tried to share a file, but when I go to “Share > Users > Address book > Directory” I have an infinite loading, without any member being displayed.

What am I doing wrong? or maybe it is a bug?

Do you use ldap for authentication ? How many user do you have in PYdio ?

I use the custom auth from external table :slight_smile:

and i have only a few members

Hi, do you have a “dual” authentication? If so, did you set the external auth as MASTER and the local sql as SLAVE?


I have under MASTER: Custom DB Auth Backend and nothing under secondary driver

Set add the pydio normal sql driver as a secondary driver, it will be used as a store for the external users.

These are my settings… but the directory of users still don’t work :frowning:


I still need assistance.


Cache master user should be Off
And depending on the number of user n ldap, the listing at the first time can take several minutes, so please increase max_execution_time

Can you post your configuration of ldap ?

Where can I find it?

This is the log appearing after trying to open the directory (don’t if it’s referred to it or something different)

Hi, maybe it’s a bug in the custom db driver

i’ve reproduced your situation and i’ve got the same error i’m going to try to find the issue meanwhile i’ll keep you updated